summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Edinaldo P. Silva2018-07-01 04:20:02 +0200
committer Willy Sudiarto Raharjo2018-07-07 01:54:12 +0200
commit79502b7afcc49fbc616523aa47f4ebe97143a81e (patch)
treec23e2f16191bef8f9f9dadb7dab8420ebdd6781f /python
parent9c2492cfe117c8eff00e12fd6cba5b4743e204f1 (diff)
downloadslackbuilds-79502b7afcc49fbc616523aa47f4ebe97143a81e.tar.gz
python/getdevinfo: Added (A device information gatherer).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/getdevinfo/README10
-rw-r--r--python/getdevinfo/getdevinfo.SlackBuild85
-rw-r--r--python/getdevinfo/getdevinfo.info10
-rw-r--r--python/getdevinfo/slack-desc19
4 files changed, 124 insertions, 0 deletions
diff --git a/python/getdevinfo/README b/python/getdevinfo/README
new file mode 100644
index 0000000000..9dbddd80b0
--- /dev/null
+++ b/python/getdevinfo/README
@@ -0,0 +1,10 @@
+getdevinfo (A device information gatherer for Linux and macOS)
+
+Working on both Linux and macOS, this script makes use of lshw,
+lvdisplay, and blkid (Linux), as well as diskutil (macOS) to get
+a comprehensive amount of disk information.
+
+This information is available in a structured dictionary for ease
+of use. On Linux it requires lshw, blkid, and lvdisplay to be
+installed. On Linux, you need beautifulsoup4 (bs4), and lxml to
+use this tool.
diff --git a/python/getdevinfo/getdevinfo.SlackBuild b/python/getdevinfo/getdevinfo.SlackBuild
new file mode 100644
index 0000000000..9b83f3e703
--- /dev/null
+++ b/python/getdevinfo/getdevinfo.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+#
+# Slackware build script for getdevinfo.
+#
+# Copyright 2018 Edinaldo P. Silva, Rio de Janeiro, Brazil.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=getdevinfo
+VERSION=${VERSION:-1.0.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py build
+python3 setup.py install --root=$PKG --optimize=1
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/getdevinfo/getdevinfo.info b/python/getdevinfo/getdevinfo.info
new file mode 100644
index 0000000000..976d3a3170
--- /dev/null
+++ b/python/getdevinfo/getdevinfo.info
@@ -0,0 +1,10 @@
+PRGNAM="getdevinfo"
+VERSION="1.0.2"
+HOMEPAGE="https://pypi.org/project/getdevinfo/"
+DOWNLOAD="https://files.pythonhosted.org/packages/81/17/eacddd7ff25f806e666383f024f1d5c7b6854b7bb699b793e005df8e5647/getdevinfo-1.0.2.tar.gz"
+MD5SUM="d4a42735ccde076c930459025fe32aa3"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="lshw lxml wheel python3"
+MAINTAINER="Edinaldo P. Silva"
+EMAIL="edps.mundognu@gmail.com"
diff --git a/python/getdevinfo/slack-desc b/python/getdevinfo/slack-desc
new file mode 100644
index 0000000000..ef965555d5
--- /dev/null
+++ b/python/getdevinfo/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+getdevinfo: getdevinfo (A device information gatherer for Linux and macOS)
+getdevinfo:
+getdevinfo: Working on both Linux and macOS, this script makes use of lshw,
+getdevinfo: lvdisplay, and blkid (Linux), as well as diskutil (macOS) to get
+getdevinfo: a comprehensive amount of disk information.
+getdevinfo:
+getdevinfo: Homepage: https://pypi.org/project/getdevinfo/
+getdevinfo:
+getdevinfo:
+getdevinfo:
+getdevinfo: