summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Isaac Yu2018-06-22 23:40:47 +0200
committer Willy Sudiarto Raharjo2018-06-23 03:44:02 +0200
commit6c78d09aa05e2a62aafe75d2150e83c753292bf2 (patch)
treefa0f3abfd13d84ac26cfae18cacdc7172f93917a /python
parent0f9b333efac6be4f710fa83bfc2a74e4b34a7a5a (diff)
downloadslackbuilds-6c78d09aa05e2a62aafe75d2150e83c753292bf2.tar.gz
python/pyudev: Updated for version 0.21.0 + new maintainer.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/pyudev/README6
-rw-r--r--python/pyudev/pyudev.SlackBuild16
-rw-r--r--python/pyudev/pyudev.info10
3 files changed, 20 insertions, 12 deletions
diff --git a/python/pyudev/README b/python/pyudev/README
index 45748e33cd..d8e6bf9d10 100644
--- a/python/pyudev/README
+++ b/python/pyudev/README
@@ -5,6 +5,8 @@ Almost the complete libudev functionality is exposed. You can:
- Enumerate devices, filtered by specific criteria (pyudev.Context)
- Query device information, properties and attributes,
-- Monitor devices, both synchronously and asynchronously with background
- threads, or within the event loops of Qt (pyudev.pyqt4, pyudev.pyside),
+- Monitor devices, both synchronously and asynchronously with background
+ threads, or within the event loops of Qt (pyudev.pyqt4, pyudev.pyside),
glib (pyudev.glib) or the optional dependency wxPython (pyudev.wx).
+
+python3 is an optional dependency (autodetected).
diff --git a/python/pyudev/pyudev.SlackBuild b/python/pyudev/pyudev.SlackBuild
index d7c0bafeb9..46a7d008ca 100644
--- a/python/pyudev/pyudev.SlackBuild
+++ b/python/pyudev/pyudev.SlackBuild
@@ -1,7 +1,8 @@
#!/bin/sh
# Slackware build script for pyudev
-# Copyright 2012 Jon Ware <jon@waremail.net>
+# Copyright 2012 Jon Ware <jon@waremail.net>
+# Copyright 2018 Isaac Yu <isaacyu1@isaacyu1.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,13 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pyudev
-VERSION=${VERSION:-0.16.1}
+VERSION=${VERSION:-0.21.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -39,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -70,6 +71,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
install -m 0644 *.txt *.rst COPYING $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/python/pyudev/pyudev.info b/python/pyudev/pyudev.info
index a387ed4bf3..9d559bf0e3 100644
--- a/python/pyudev/pyudev.info
+++ b/python/pyudev/pyudev.info
@@ -1,10 +1,10 @@
PRGNAM="pyudev"
-VERSION="0.16.1"
+VERSION="0.21.0"
HOMEPAGE="http://pyudev.readthedocs.org"
-DOWNLOAD="https://pypi.python.org/packages/source/p/pyudev/pyudev-0.16.1.tar.gz"
-MD5SUM="4034de584b6d9efcbfc590a047c63285"
+DOWNLOAD="https://pypi.python.org/packages/source/p/pyudev/pyudev-0.21.0.tar.gz"
+MD5SUM="cf4d9db7d772622144ca1be6b5d9353b"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Jon Ware"
-EMAIL="jon@waremail.net"
+MAINTAINER="Isaac Yu"
+EMAIL="isaacyu1@isaacyu1.com"