summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author David Spencer2018-07-01 11:51:17 +0200
committer David Spencer2018-07-01 11:51:17 +0200
commit57fb210c8b46c416e9e17017be595e7cdfa4942b (patch)
treed62219619e4b83cbe5eef2311d45453d5c5a9063 /python
parent12d04f0a6618742c90ebdfe692cf352a7b4570b9 (diff)
downloadslackbuilds-57fb210c8b46c416e9e17017be595e7cdfa4942b.tar.gz
python/python-evdev: Fix permissions.
Upstream shipped the 1.0.0 release with 660 permissions. This led to files in the built package being readable only by root (notably in the egg-info directory, but also the licence), which broke system/ds4drv, and possibly libinput. Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-evdev/python-evdev.SlackBuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/python/python-evdev/python-evdev.SlackBuild b/python/python-evdev/python-evdev.SlackBuild
index 39f0176749..a4081dfcbe 100644
--- a/python/python-evdev/python-evdev.SlackBuild
+++ b/python/python-evdev/python-evdev.SlackBuild
@@ -70,6 +70,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# ... but upstream shipped evdev-1.0.0 with 660 permissions everywhere, so:
+find -L . -perm 660 -exec chmod 644 {} \;
+
python setup.py install --root=$PKG
if hash python3 ; then