summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author dsomero2012-08-17 00:39:53 +0200
committer Robby Workman2012-08-18 06:07:42 +0200
commitb44e46f420e3dc70162b97df9a107617a16f538c (patch)
tree069492b0b24aa301fd8efe8f19a7c3d8b76a8a8e /python
parent39740556f8bf9ad544d30d7b76eec2791c4c28ed (diff)
downloadslackbuilds-b44e46f420e3dc70162b97df9a107617a16f538c.tar.gz
python/pycurl: Removed (part of Slackware 14.0)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org> Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/pycurl/README3
-rw-r--r--python/pycurl/pycurl.SlackBuild73
-rw-r--r--python/pycurl/pycurl.info9
-rw-r--r--python/pycurl/slack-desc19
4 files changed, 0 insertions, 104 deletions
diff --git a/python/pycurl/README b/python/pycurl/README
deleted file mode 100644
index 135071beb8..0000000000
--- a/python/pycurl/README
+++ /dev/null
@@ -1,3 +0,0 @@
-PycURL is a Python interface to libcurl. PycURL can be used to fetch
-objects identified by a URL from a Python program, similar to the urllib
-Python module. PycURL is mature, very fast, and supports a lot of features.
diff --git a/python/pycurl/pycurl.SlackBuild b/python/pycurl/pycurl.SlackBuild
deleted file mode 100644
index ed6ea11041..0000000000
--- a/python/pycurl/pycurl.SlackBuild
+++ /dev/null
@@ -1,73 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for pycurl
-
-# Written by Grissiom chaos.proton@gmail.com
-# Updated by LukenShiro <lukenshiro@ngi.it>
-
-PRGNAM=pycurl
-VERSION=${VERSION:-7.19.0}
-BUILD=${BUILD:-2}
-TAG=${TAG:-_SBo}
-
-# Automatically determine the architecture we're building on:
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e # Exit on most errors
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p ${PKG}/usr/doc/$PRGNAM-$VERSION
-mv ${PKG}/usr/share/doc/${PRGNAM}/* -t ${PKG}/usr/doc/$PRGNAM-$VERSION
-rm -rf ${PKG}/usr/share
-
-cp PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pycurl/pycurl.info b/python/pycurl/pycurl.info
deleted file mode 100644
index 3e712a2e3e..0000000000
--- a/python/pycurl/pycurl.info
+++ /dev/null
@@ -1,9 +0,0 @@
-PRGNAM="pycurl"
-VERSION="7.19.0"
-HOMEPAGE="http://pycurl.sourceforge.net/"
-DOWNLOAD="http://pycurl.sourceforge.net/download/pycurl-7.19.0.tar.gz"
-MD5SUM="919d58fe37e69fe87ce4534d8b6a1c7b"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="LukenShiro"
-EMAIL="lukenshiro@ngi.it"
diff --git a/python/pycurl/slack-desc b/python/pycurl/slack-desc
deleted file mode 100644
index 6d91ef6e87..0000000000
--- a/python/pycurl/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|' on
-# the right side marks the last column you can put a character in. You must make
-# exactly 11 lines for the formatting to be correct. It's also customary to
-# leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-pycurl: PycURL (Python interface to libcurl).
-pycurl:
-pycurl: libcurl is a free and easy-to-use client-side URL transfer library,
-pycurl: supporting FTP, FTPS, HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and
-pycurl: LDAP. libcurl supports HTTPS certificates, HTTP POST, HTTP PUT,
-pycurl: FTP uploading, kerberos, HTTP form based upload, proxies, cookies,
-pycurl: user+password authentication, file transfer resume, http proxy
-pycurl: tunneling and more!
-pycurl:
-pycurl: Homepage:http://pycurl.sourceforge.net/
-pycurl: