summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Rob van Nues2017-09-10 12:52:41 +0200
committer Willy Sudiarto Raharjo2017-09-16 02:15:00 +0200
commit4d2baae773503a795b124331c9b813144fcbc277 (patch)
treeff0dd0dbeba6142b9900b4c7cab9e0b84f55cec4 /python
parent52f75bd0fd51af0098d60584c8129b6d26bacb25 (diff)
downloadslackbuilds-4d2baae773503a795b124331c9b813144fcbc277.tar.gz
python/ruffus: Added (Computation Pipeline library).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/ruffus/README10
-rw-r--r--python/ruffus/ruffus.SlackBuild88
-rw-r--r--python/ruffus/ruffus.info10
-rw-r--r--python/ruffus/slack-desc19
4 files changed, 127 insertions, 0 deletions
diff --git a/python/ruffus/README b/python/ruffus/README
new file mode 100644
index 0000000000..8086f4afd9
--- /dev/null
+++ b/python/ruffus/README
@@ -0,0 +1,10 @@
+Ruffus is a Computation Pipeline library for python. It is
+open-sourced, powerful and user-friendly, and widely used in science
+and bioinformatics. Ruffus is designed to allow scientific and other
+analyses to be automated with the minimum of fuss and the least effort.
+
+Please cite Ruffus as: Leo Goodstadt (2010): Ruffus: a lightweight
+Python library for computational pipelines. Bioinformatics 26(21):
+2778-2779
+
+Optional requirement: graphviz
diff --git a/python/ruffus/ruffus.SlackBuild b/python/ruffus/ruffus.SlackBuild
new file mode 100644
index 0000000000..cb46a64ad3
--- /dev/null
+++ b/python/ruffus/ruffus.SlackBuild
@@ -0,0 +1,88 @@
+#!/bin/sh
+
+# Slackware build script for ruffus
+
+# Copyright 2017 Rob van Nues
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=ruffus
+VERSION=${VERSION:-20160417}
+COMMIT=${COMMIT:-f669a3f5b22bbd6b68cb0ff5efd590220e5ed665}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$COMMIT
+tar xvf $CWD/$PRGNAM-$COMMIT.tar.gz
+cd $PRGNAM-$COMMIT
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README.rst LICENSE.TXT CHANGES.TXT MANIFEST USAGE.TXT \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/ruffus/ruffus.info b/python/ruffus/ruffus.info
new file mode 100644
index 0000000000..88b4431990
--- /dev/null
+++ b/python/ruffus/ruffus.info
@@ -0,0 +1,10 @@
+PRGNAM="ruffus"
+VERSION="20160417"
+HOMEPAGE="http://www.ruffus.org.uk"
+DOWNLOAD="https://github.com/bunbun/ruffus/archive/f669a3f/ruffus-f669a3f5b22bbd6b68cb0ff5efd590220e5ed665.tar.gz"
+MD5SUM="45cf4b96159f0d85397a0fd4f58c75eb"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Rob van Nues"
+EMAIL="rvnues at tesco {dot} net"
diff --git a/python/ruffus/slack-desc b/python/ruffus/slack-desc
new file mode 100644
index 0000000000..f6c237018b
--- /dev/null
+++ b/python/ruffus/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+ruffus: ruffus (Computation Pipeline library)
+ruffus:
+ruffus: Ruffus is a Computation Pipeline library for Python designed to allow
+ruffus: scientific and other analyses to be automated with the minimum of
+ruffus: fuss and the least effort.
+ruffus:
+ruffus: http://www.ruffus.org.uk
+ruffus:
+ruffus:
+ruffus:
+ruffus: