summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Thibaut Notteboom2015-04-03 11:15:54 +0200
committer Willy Sudiarto Raharjo2015-04-03 15:50:22 +0200
commitb6ed5eab0f3effc5ad991ada88e6e9df54d3af8e (patch)
tree30aa73610c543a515b936823ebe7a37ef97d0553 /python
parent402accb9ad4aaa3f5ea3f1bdd2e43d041b7e61ea (diff)
downloadslackbuilds-b6ed5eab0f3effc5ad991ada88e6e9df54d3af8e.tar.gz
python/Pyro: Updated for version 3.16.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/Pyro/Pyro.SlackBuild31
-rw-r--r--python/Pyro/Pyro.info8
2 files changed, 29 insertions, 10 deletions
diff --git a/python/Pyro/Pyro.SlackBuild b/python/Pyro/Pyro.SlackBuild
index 680fc1506e..1e0c310c90 100644
--- a/python/Pyro/Pyro.SlackBuild
+++ b/python/Pyro/Pyro.SlackBuild
@@ -1,10 +1,29 @@
#!/bin/sh
# Slackware build script for Pyro
-# Written by Thibaut Notteboom (tib@tibux.org)
+
+# Copyright 2015 Thibaut Notteboom, Paris, FRANCE
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=Pyro
-VERSION=${VERSION:-3.15}
+VERSION=${VERSION:-3.16}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -45,10 +64,10 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
diff --git a/python/Pyro/Pyro.info b/python/Pyro/Pyro.info
index 15b4787745..703b303d86 100644
--- a/python/Pyro/Pyro.info
+++ b/python/Pyro/Pyro.info
@@ -1,8 +1,8 @@
PRGNAM="Pyro"
-VERSION="3.15"
-HOMEPAGE="http://www.xs4all.nl/~irmen/pyro3/"
-DOWNLOAD="http://pypi.python.org/packages/source/P/Pyro/Pyro-3.15.tar.gz"
-MD5SUM="aa93ed5fd0987ab8e68bb52c021f0398"
+VERSION="3.16"
+HOMEPAGE="https://pypi.python.org/pypi/Pyro/3.16"
+DOWNLOAD="https://pypi.python.org/packages/source/P/Pyro/Pyro-3.16.tar.gz"
+MD5SUM="59d4d3f4a8786776c9d7f9051b8f1a69"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""