summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Dimitris Zlatanidis2015-06-07 16:33:55 +0200
committer Willy Sudiarto Raharjo2015-06-07 16:33:55 +0200
commit08072a44d0a9aa7663849ff59e2a582fff41e625 (patch)
treed87279a5ebda91273b57e9edec3493087ee4fbd1 /python
parent1ef75b0d98a5a2d3231cb95503efdeba0b0078f6 (diff)
downloadslackbuilds-08072a44d0a9aa7663849ff59e2a582fff41e625.tar.gz
python/functools32: Added (Backport Python library).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/functools32/README3
-rw-r--r--python/functools32/functools32.SlackBuild86
-rw-r--r--python/functools32/functools32.info10
-rw-r--r--python/functools32/slack-desc19
4 files changed, 118 insertions, 0 deletions
diff --git a/python/functools32/README b/python/functools32/README
new file mode 100644
index 0000000000..0773d8896f
--- /dev/null
+++ b/python/functools32/README
@@ -0,0 +1,3 @@
+This is a backport of the functools standard library module
+from Python 3.2.3 for use on Python 2.7 and PyPy. It includes
+new features lru_cache (Least-recently-used cache decorator).
diff --git a/python/functools32/functools32.SlackBuild b/python/functools32/functools32.SlackBuild
new file mode 100644
index 0000000000..71dbc56ae1
--- /dev/null
+++ b/python/functools32/functools32.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for functools32
+
+# Copyright 2015 Dimitris Zlatanidis Orestiada, Greece
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=functools32
+SRCVER=${SRCVER:-3.2.3-1}
+VERSION=$(echo $SRCVER | tr - _)
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$SRCVER
+tar xvf $CWD/$PRGNAM-$SRCVER.tar.gz
+cd $PRGNAM-$SRCVER
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a ChangeLog LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/functools32/functools32.info b/python/functools32/functools32.info
new file mode 100644
index 0000000000..2696fbffda
--- /dev/null
+++ b/python/functools32/functools32.info
@@ -0,0 +1,10 @@
+PRGNAM="functools32"
+VERSION="3.2.3_1"
+HOMEPAGE="https://github.com/MiCHiLU/python-functools32"
+DOWNLOAD="https://pypi.python.org/packages/source/f/functools32/functools32-3.2.3-1.tar.gz"
+MD5SUM="6c226dfc1ca56ba3ee200d603b780cbc"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/functools32/slack-desc b/python/functools32/slack-desc
new file mode 100644
index 0000000000..5334a4c7cf
--- /dev/null
+++ b/python/functools32/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+functools32: functools32 (Backport Python library)
+functools32:
+functools32: This is a backport of the functools standard library module from
+functools32: Python 3.2.3 for use on Python 2.7 and PyPy. It includes new features
+functools32: lru_cache (Least-recently-used cache decorator).
+functools32:
+functools32: Homepage: https://github.com/MiCHiLU/python-functools32
+functools32:
+functools32:
+functools32:
+functools32: