summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Larry Hajali2012-12-03 05:07:25 +0100
committer dsomero2012-12-11 22:20:49 +0100
commit9de268421a164e3ca90d1789822369cadcc094ad (patch)
treeb3fef04851664cef36a8b6975fa42b0c5e02696a /python
parente8c2184dd8a46e5f2325cb61f96c92533fd3b8cb (diff)
downloadslackbuilds-9de268421a164e3ca90d1789822369cadcc094ad.tar.gz
python/python-distutils-extra: Updated for version 2.37.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python-distutils-extra/python-distutils-extra.SlackBuild13
-rw-r--r--python/python-distutils-extra/python-distutils-extra.info6
2 files changed, 12 insertions, 7 deletions
diff --git a/python/python-distutils-extra/python-distutils-extra.SlackBuild b/python/python-distutils-extra/python-distutils-extra.SlackBuild
index ef45067248..b4b59e6dec 100644
--- a/python/python-distutils-extra/python-distutils-extra.SlackBuild
+++ b/python/python-distutils-extra/python-distutils-extra.SlackBuild
@@ -5,7 +5,7 @@
# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
PRGNAM=python-distutils-extra
-VERSION=2.32
+VERSION=${VERSION:-2.37}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -37,15 +37,20 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# Build extra options.
+cat >> setup.cfg << EOF
+[build]
+i18n=True
+icons=True
+EOF
+
python setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- LICENSE PKG-INFO doc/{FAQ,README} \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE PKG-INFO doc/{FAQ,README} $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/python-distutils-extra/python-distutils-extra.info b/python/python-distutils-extra/python-distutils-extra.info
index 5ea60f08e4..0b34f5cc55 100644
--- a/python/python-distutils-extra/python-distutils-extra.info
+++ b/python/python-distutils-extra/python-distutils-extra.info
@@ -1,8 +1,8 @@
PRGNAM="python-distutils-extra"
-VERSION="2.32"
+VERSION="2.37"
HOMEPAGE="https://launchpad.net/python-distutils-extra"
-DOWNLOAD="https://launchpad.net/python-distutils-extra/trunk/2.32/+download/python-distutils-extra-2.32.tar.gz"
-MD5SUM="034b6594d10084bb49d99c1511b30187"
+DOWNLOAD="https://launchpad.net/python-distutils-extra/trunk/2.37/+download/python-distutils-extra-2.37.tar.gz"
+MD5SUM="52cffcd6e8e17ed5aa2f9303683333ef"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="distribute"