summaryrefslogtreecommitdiffstats
path: root/python/traitlets
diff options
context:
space:
mode:
author Isaac Yu2022-06-02 20:17:06 +0200
committer Willy Sudiarto Raharjo2022-06-04 05:37:23 +0200
commit40583ae9700a36b6c8d6b37ed082ae59716ed166 (patch)
treea20884db5883f1fc18e939d2b04f6836c418b453 /python/traitlets
parent31d06fb0128ded0c4c2b4c658714a40aae026613 (diff)
downloadslackbuilds-40583ae9700a36b6c8d6b37ed082ae59716ed166.tar.gz
python/traitlets: Update for 5.2.2
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/traitlets')
-rw-r--r--python/traitlets/traitlets.SlackBuild25
-rw-r--r--python/traitlets/traitlets.info6
2 files changed, 25 insertions, 6 deletions
diff --git a/python/traitlets/traitlets.SlackBuild b/python/traitlets/traitlets.SlackBuild
index 8b71cc8c54..afa52e6a0b 100644
--- a/python/traitlets/traitlets.SlackBuild
+++ b/python/traitlets/traitlets.SlackBuild
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=traitlets
-VERSION=${VERSION:-5.1.1}
+VERSION=${VERSION:-5.2.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -80,14 +80,33 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+# Use this setup.py shim:
+cat << EOF > setup.py
+from distutils.core import setup
+import os
+here = os.path.abspath(os.path.dirname(__file__))
+pjoin = os.path.join
+packages = []
+for d, _, _ in os.walk(pjoin(here, 'traitlets')):
+ if os.path.exists(pjoin(d, '__init__.py')):
+ packages.append(d[len(here)+1:].replace(os.path.sep, '.'))
+setup(name='${PRGNAM}',
+ version='${VERSION}',
+ packages=packages,
+ package_data={'': ['*']},
+)
+EOF
+
+# With the shim, it's a good idea to use "unshare -n" to prevent downloading
+# anything extra:
+unshare -n python3 setup.py install --root=$PKG || exit 1
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- CHANGES.txt CONTRIBUTING.md COPYING.md README.md docs/ \
+ CHANGES.txt CONTRIBUTING.md COPYING.md README.md \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/python/traitlets/traitlets.info b/python/traitlets/traitlets.info
index 38ea62ed21..3bf3573b34 100644
--- a/python/traitlets/traitlets.info
+++ b/python/traitlets/traitlets.info
@@ -1,8 +1,8 @@
PRGNAM="traitlets"
-VERSION="5.1.1"
+VERSION="5.2.2"
HOMEPAGE="https://jupyter.org/"
-DOWNLOAD="https://github.com/ipython/traitlets/archive/5.1.1/traitlets-5.1.1.tar.gz"
-MD5SUM="47ccdf0ac59b1818956bf8f6f6534aac"
+DOWNLOAD="https://github.com/ipython/traitlets/archive/5.2.2/traitlets-5.2.2.tar.gz"
+MD5SUM="720e22fd704d888eccbfd474f54a1401"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="decorator"