summaryrefslogtreecommitdiffstats
path: root/python/simplejson/simplejson.SlackBuild
diff options
context:
space:
mode:
author Larry Hajali2014-07-06 02:32:17 +0200
committer Robby Workman2014-07-07 07:00:39 +0200
commit29e6753433908db1c3a5d14cabbdf15b23eb6e6f (patch)
treed166f5878e9ab54557908817429881e75b528dbc /python/simplejson/simplejson.SlackBuild
parent0ba88ac1e63551fc0864c56dff74edde0d70bcd0 (diff)
downloadslackbuilds-29e6753433908db1c3a5d14cabbdf15b23eb6e6f.tar.gz
python/simplejson: Updated for version 3.5.3.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/simplejson/simplejson.SlackBuild')
-rw-r--r--python/simplejson/simplejson.SlackBuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/python/simplejson/simplejson.SlackBuild b/python/simplejson/simplejson.SlackBuild
index aa9e3dd57e..588fabb55b 100644
--- a/python/simplejson/simplejson.SlackBuild
+++ b/python/simplejson/simplejson.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for simplejson
-# Copyright 2009-2013 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2009-2014 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=simplejson
-VERSION=${VERSION:-3.3.1}
+VERSION=${VERSION:-3.5.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -50,10 +50,10 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Make documents if Sphinx and Pygments are installed.
if $(python -c 'import sphinx.pygments_styles' 2>/dev/null); then
@@ -62,7 +62,11 @@ fi
python setup.py install --root=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+if $(python3 -c 'import os' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION