summaryrefslogtreecommitdiffstats
path: root/python/s3cmd/s3cmd.SlackBuild
diff options
context:
space:
mode:
author Larry Hajali2012-05-13 15:10:06 +0200
committer dsomero2012-05-13 15:10:06 +0200
commitade5ee96ae8ee923a461d347864e35e1bf4f2cbe (patch)
tree6f4e18187a8f2490f82b5a71e889c1edbb38452c /python/s3cmd/s3cmd.SlackBuild
parent3d34f836d0088c055c74b67c5b9af81e9db8c9b2 (diff)
downloadslackbuilds-ade5ee96ae8ee923a461d347864e35e1bf4f2cbe.tar.gz
python/s3cmd: Added (Amazon S3 command line tool)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'python/s3cmd/s3cmd.SlackBuild')
-rw-r--r--python/s3cmd/s3cmd.SlackBuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/python/s3cmd/s3cmd.SlackBuild b/python/s3cmd/s3cmd.SlackBuild
new file mode 100644
index 0000000000..1899a56c40
--- /dev/null
+++ b/python/s3cmd/s3cmd.SlackBuild
@@ -0,0 +1,57 @@
+#!/bin/sh
+
+# Slackware build script for s3cmd
+
+# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+
+PRGNAM=s3cmd
+VERSION=${VERSION:-1.1.0_beta3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-${VERSION/_/-}
+tar xvf $CWD/$PRGNAM-${VERSION/_/-}.tar.gz
+cd $PRGNAM-${VERSION/_/-}
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+sed -i 's|\(doc_path\)+"/s3cmd"|\1|' setup.py
+
+S3CMD_INSTPATH_DOC="/usr/doc/$PRGNAM-$VERSION" \
+S3CMD_INSTPATH_MAN="/usr/man" \
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}