summaryrefslogtreecommitdiffstats
path: root/python/requests-toolbelt
diff options
context:
space:
mode:
author Dimitris Zlatanidis2017-03-09 20:21:11 +0100
committer Willy Sudiarto Raharjo2017-03-11 01:04:13 +0100
commite5182831cce5e8c36ae918157a86a1e4a38245d7 (patch)
tree7e6b56b31afa78eac7e695d0b11d46a83cf074bb /python/requests-toolbelt
parent65dd9f4d5fa9b984810d34d7220bbb787df0845f (diff)
downloadslackbuilds-e5182831cce5e8c36ae918157a86a1e4a38245d7.tar.gz
python/requests-toolbelt: Updated for version 0.7.1.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'python/requests-toolbelt')
-rw-r--r--python/requests-toolbelt/requests-toolbelt.SlackBuild9
-rw-r--r--python/requests-toolbelt/requests-toolbelt.info6
2 files changed, 10 insertions, 5 deletions
diff --git a/python/requests-toolbelt/requests-toolbelt.SlackBuild b/python/requests-toolbelt/requests-toolbelt.SlackBuild
index c8772b06e1..a044bec034 100644
--- a/python/requests-toolbelt/requests-toolbelt.SlackBuild
+++ b/python/requests-toolbelt/requests-toolbelt.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for requests-toolbelt
-# Copyright 2016 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2016-2017 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=requests-toolbelt
-VERSION=${VERSION:-0.7.0}
+VERSION=${VERSION:-0.7.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -71,6 +71,11 @@ find -L . \
python setup.py install --root=$PKG
+# python3 support
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/requests-toolbelt/requests-toolbelt.info b/python/requests-toolbelt/requests-toolbelt.info
index c681af9144..1a1dbf4bdf 100644
--- a/python/requests-toolbelt/requests-toolbelt.info
+++ b/python/requests-toolbelt/requests-toolbelt.info
@@ -1,8 +1,8 @@
PRGNAM="requests-toolbelt"
-VERSION="0.7.0"
+VERSION="0.7.1"
HOMEPAGE="https://toolbelt.readthedocs.io/en/latest/"
-DOWNLOAD="https://pypi.python.org/packages/59/78/1d391d30ebf74079a8e4de6ab66fdca5362903ef2df64496f4697e9bb626/requests-toolbelt-0.7.0.tar.gz"
-MD5SUM="bfe2009905f460f4764c32cfbbf4205f"
+DOWNLOAD="https://pypi.python.org/packages/ab/bf/2af6b25f880e2d529a524f98837d33b1048a2a15703fc4806185b54e9672/requests-toolbelt-0.7.1.tar.gz"
+MD5SUM="be245e2093a9610fb2eb399afc063ad2"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python-requests"