summaryrefslogtreecommitdiffstats
path: root/python/python3/patches/python3.no-static-library.diff
diff options
context:
space:
mode:
author Audrius Kažukauskas2014-10-09 21:26:44 +0200
committer Willy Sudiarto Raharjo2014-10-11 13:18:43 +0200
commit208917a22e109c34001f90727d969df019e62421 (patch)
treeacbd70f53e747019a5a207c4c5c90f158c49651a /python/python3/patches/python3.no-static-library.diff
parentece37efc9970a40a8f1e0e42b660d9fe34796a01 (diff)
downloadslackbuilds-208917a22e109c34001f90727d969df019e62421.tar.gz
python/python3: Updated for version 3.4.2.
Signed-off-by: Audrius Kažukauskas <audrius@neutrino.lt>
Diffstat (limited to 'python/python3/patches/python3.no-static-library.diff')
-rw-r--r--python/python3/patches/python3.no-static-library.diff14
1 files changed, 7 insertions, 7 deletions
diff --git a/python/python3/patches/python3.no-static-library.diff b/python/python3/patches/python3.no-static-library.diff
index bbc0e3a817..442373021c 100644
--- a/python/python3/patches/python3.no-static-library.diff
+++ b/python/python3/patches/python3.no-static-library.diff
@@ -1,7 +1,7 @@
-diff -uar Python-3.4.0.orig/Makefile.pre.in Python-3.4.0/Makefile.pre.in
---- Python-3.4.0.orig/Makefile.pre.in 2014-03-17 04:31:30.000000000 +0200
-+++ Python-3.4.0/Makefile.pre.in 2014-03-29 12:27:38.788419450 +0200
-@@ -532,7 +532,7 @@
+diff -uar Python-3.4.2.orig/Makefile.pre.in Python-3.4.2/Makefile.pre.in
+--- Python-3.4.2.orig/Makefile.pre.in 2014-10-08 11:18:14.000000000 +0300
++++ Python-3.4.2/Makefile.pre.in 2014-10-09 21:12:08.504150485 +0300
+@@ -537,7 +537,7 @@
$(RUNSHARED) $(PYTHON_FOR_BUILD) ./Tools/clinic/clinic.py --make
# Build the interpreter
@@ -10,7 +10,7 @@ diff -uar Python-3.4.0.orig/Makefile.pre.in Python-3.4.0/Makefile.pre.in
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Modules/python.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
platform: $(BUILDPYTHON) pybuilddir.txt
-@@ -557,18 +557,6 @@
+@@ -572,18 +572,6 @@
_TCLTK_INCLUDES='$(TCLTK_INCLUDES)' _TCLTK_LIBS='$(TCLTK_LIBS)' \
$(PYTHON_FOR_BUILD) $(srcdir)/setup.py $$quiet build
@@ -29,7 +29,7 @@ diff -uar Python-3.4.0.orig/Makefile.pre.in Python-3.4.0/Makefile.pre.in
libpython$(LDVERSION).so: $(LIBRARY_OBJS)
if test $(INSTSONAME) != $(LDLIBRARY); then \
$(BLDSHARED) -Wl,-h$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST); \
-@@ -658,7 +646,7 @@
+@@ -673,7 +661,7 @@
echo "-----------------------------------------------"; \
fi
@@ -38,7 +38,7 @@ diff -uar Python-3.4.0.orig/Makefile.pre.in Python-3.4.0/Makefile.pre.in
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Modules/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
############################################################################
-@@ -1309,18 +1297,6 @@
+@@ -1324,18 +1312,6 @@
else true; \
fi; \
done