summaryrefslogtreecommitdiffstats
path: root/python/python3-zxcvbn-python
diff options
context:
space:
mode:
author fourtysixandtwo2023-09-08 15:47:48 +0200
committer Willy Sudiarto Raharjo2023-09-09 05:14:19 +0200
commit2f20d753ccf8062d768c0688f0b0cafec9185895 (patch)
tree9b21f0103d88dedec546e08e22b090aea94ddf83 /python/python3-zxcvbn-python
parentba753c93621450bdbacd0daf716447deb617535b (diff)
downloadslackbuilds-2f20d753ccf8062d768c0688f0b0cafec9185895.tar.gz
python/python3-zxcvbn-python: Update README and SlackBuild.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-zxcvbn-python')
-rw-r--r--python/python3-zxcvbn-python/README6
-rw-r--r--python/python3-zxcvbn-python/python3-zxcvbn-python.SlackBuild12
2 files changed, 12 insertions, 6 deletions
diff --git a/python/python3-zxcvbn-python/README b/python/python3-zxcvbn-python/README
index 3fb1244c61..69a5d2f5f1 100644
--- a/python/python3-zxcvbn-python/README
+++ b/python/python3-zxcvbn-python/README
@@ -1,2 +1,8 @@
Python implementation of Dropbox's realistic password strength
estimator.
+
+Note:
+ This is the last version with the module name "zxcvbn-python".
+ -"binary" renamed to zxcvbn-python
+ -(use python3-zxcvbn slackbuild if "zxcvbn" is required)
+ -will be removed once it's no longer a dependency for anything
diff --git a/python/python3-zxcvbn-python/python3-zxcvbn-python.SlackBuild b/python/python3-zxcvbn-python/python3-zxcvbn-python.SlackBuild
index 6621aacb59..c5a5c743cd 100644
--- a/python/python3-zxcvbn-python/python3-zxcvbn-python.SlackBuild
+++ b/python/python3-zxcvbn-python/python3-zxcvbn-python.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-zxcvbn-python
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -76,12 +73,15 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
python3 setup.py install --root=$PKG
+# rename "binary" so it does not conflict with new slackbuild python3-zxcvbn
+mv $PKG/usr/bin/zxcvbn $PKG/usr/bin/zxcvbn-python
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true