summaryrefslogtreecommitdiffstats
path: root/python/python3-vine
diff options
context:
space:
mode:
author Yth - Arnaud2024-01-11 07:01:26 +0100
committer Willy Sudiarto Raharjo2024-01-11 15:15:09 +0100
commitbae8c45cb30dd610bc36b9f7f3033c6ab8160327 (patch)
tree44a76f66753d32f505b2a7df4ceaaca9374eaf9f /python/python3-vine
parent538cd39b6f856f89e88ce7b00d4c87970facf74f (diff)
downloadslackbuilds-bae8c45cb30dd610bc36b9f7f3033c6ab8160327.tar.gz
python/python3-vine: Added (Python3 version of Vine).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-vine')
-rw-r--r--python/python3-vine/README1
-rw-r--r--python/python3-vine/python3-vine.SlackBuild77
-rw-r--r--python/python3-vine/python3-vine.info10
-rw-r--r--python/python3-vine/slack-desc19
4 files changed, 107 insertions, 0 deletions
diff --git a/python/python3-vine/README b/python/python3-vine/README
new file mode 100644
index 0000000000..4b83089577
--- /dev/null
+++ b/python/python3-vine/README
@@ -0,0 +1 @@
+A Python module promise, async, future.
diff --git a/python/python3-vine/python3-vine.SlackBuild b/python/python3-vine/python3-vine.SlackBuild
new file mode 100644
index 0000000000..a24eea9fbb
--- /dev/null
+++ b/python/python3-vine/python3-vine.SlackBuild
@@ -0,0 +1,77 @@
+#!/bin/bash
+
+# SlackBuild build script for python3-vine
+
+# Copyright (c) 2000-2020 Prof. Horstmann <wmh (at) eipg.fr>
+# Copyright 2023 Yth | Pont-en-Royans, France | yth@ythogtha.org
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-vine
+SRCNAM=${PRGNAM#python3-*}
+VERSION=${VERSION:-5.1.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+python3 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-vine/python3-vine.info b/python/python3-vine/python3-vine.info
new file mode 100644
index 0000000000..3fc3bb36a0
--- /dev/null
+++ b/python/python3-vine/python3-vine.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-vine"
+VERSION="5.1.0"
+HOMEPAGE="https://pypi.org/project/vine/"
+DOWNLOAD="https://pypi.python.org/packages/source/v/vine/vine-5.1.0.tar.gz"
+MD5SUM="eb53f54bbe9b6b4d65f072972cea0fcd"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/python3-vine/slack-desc b/python/python3-vine/slack-desc
new file mode 100644
index 0000000000..a657ef44d0
--- /dev/null
+++ b/python/python3-vine/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-vine: python3-vine (promise, async, future)
+python3-vine:
+python3-vine: Homepage: https://pypi.org/project/vine/
+python3-vine:
+python3-vine:
+python3-vine:
+python3-vine:
+python3-vine:
+python3-vine:
+python3-vine:
+python3-vine: