summaryrefslogtreecommitdiffstats
path: root/python/python3-decorator
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2017-04-16 09:57:13 +0200
committer Willy Sudiarto Raharjo2017-04-16 09:57:13 +0200
commitcf8b6083449be46acc3818b2973a92c1a9d6eacf (patch)
treeb9c3f706259e030ddd79ade9a836a88df87c9ebe /python/python3-decorator
parente3a7f534fd94120a41f622fc1516037b8ecee791 (diff)
downloadslackbuilds-cf8b6083449be46acc3818b2973a92c1a9d6eacf.tar.gz
python/python3-decorator: Added (decorator module for Python 3).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-decorator')
-rw-r--r--python/python3-decorator/README4
-rw-r--r--python/python3-decorator/python3-decorator.SlackBuild70
-rw-r--r--python/python3-decorator/python3-decorator.info10
-rw-r--r--python/python3-decorator/slack-desc19
4 files changed, 103 insertions, 0 deletions
diff --git a/python/python3-decorator/README b/python/python3-decorator/README
new file mode 100644
index 0000000000..d1d2a840af
--- /dev/null
+++ b/python/python3-decorator/README
@@ -0,0 +1,4 @@
+The aim of the decorator module it to simplify the usage of decorators
+for the average programmer, and to popularize decorators usage giving
+examples of useful decorators, such as memoize, tracing,
+redirecting_stdout, locked, etc.
diff --git a/python/python3-decorator/python3-decorator.SlackBuild b/python/python3-decorator/python3-decorator.SlackBuild
new file mode 100644
index 0000000000..60e871a627
--- /dev/null
+++ b/python/python3-decorator/python3-decorator.SlackBuild
@@ -0,0 +1,70 @@
+#!/bin/sh
+
+# Slackware build script for python3-decorator
+
+# Copyright 2013 Mikko Värri, Finland
+# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+SRCNAM=decorator
+PRGNAM=python3-$SRCNAM
+VERSION=${VERSION:-4.0.11}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES.md LICENSE.txt docs/README.rst $PKG/usr/doc/$PRGNAM-$VERSION/
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-decorator/python3-decorator.info b/python/python3-decorator/python3-decorator.info
new file mode 100644
index 0000000000..5c2bcc84e4
--- /dev/null
+++ b/python/python3-decorator/python3-decorator.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-decorator"
+VERSION="4.0.11"
+HOMEPAGE="http://pypi.python.org/pypi/decorator"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/d/decorator/decorator-4.0.11.tar.gz"
+MD5SUM="73644c8f0bd4983d1b6a34b49adec0ae"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3"
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="slackbuilds@jaxartes.net"
diff --git a/python/python3-decorator/slack-desc b/python/python3-decorator/slack-desc
new file mode 100644
index 0000000000..ee16049cea
--- /dev/null
+++ b/python/python3-decorator/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-decorator: python3-decorator (decorator module for Python 3)
+python3-decorator:
+python3-decorator: The aim of the decorator module it to simplify the usage of
+python3-decorator: decorators for the average programmer, and to popularize decorators
+python3-decorator: usage giving examples of useful decorators, such as memoize, tracing,
+python3-decorator: redirecting_stdout, locked, etcetera.
+python3-decorator:
+python3-decorator: http://www.phyast.pitt.edu/~micheles/python/documentation.html
+python3-decorator:
+python3-decorator:
+python3-decorator: