summaryrefslogtreecommitdiffstats
path: root/python/python3-ZConfig
diff options
context:
space:
mode:
author Yth - Arnaud2023-07-08 03:49:10 +0200
committer Willy Sudiarto Raharjo2023-07-08 03:49:10 +0200
commit34fa031e54d37aa6f539ffa09914ed350646b938 (patch)
tree526ca8d7be089b78f980a1aed50f5436a20cf4ca /python/python3-ZConfig
parent61772be0c5e6847795fd850f4e1c7a3f8868f8de (diff)
downloadslackbuilds-34fa031e54d37aa6f539ffa09914ed350646b938.tar.gz
python/python3-ZConfig: Added (Structured Configuration Library).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-ZConfig')
-rw-r--r--python/python3-ZConfig/README20
-rw-r--r--python/python3-ZConfig/python3-ZConfig.SlackBuild74
-rw-r--r--python/python3-ZConfig/python3-ZConfig.info10
-rw-r--r--python/python3-ZConfig/slack-desc19
4 files changed, 123 insertions, 0 deletions
diff --git a/python/python3-ZConfig/README b/python/python3-ZConfig/README
new file mode 100644
index 0000000000..f6394c16ca
--- /dev/null
+++ b/python/python3-ZConfig/README
@@ -0,0 +1,20 @@
+ZConfig: Schema-driven configuration
+
+ZConfig is a configuration library intended for general use.
+It supports a hierarchical schema-driven configuration model that
+allows a schema to specify data conversion routines written in Python.
+ZConfig’s model is very different from the model supported by the
+ConfigParser module found in Python’s standard library, and is more
+suitable to configuration-intensive applications.
+
+ZConfig schema are written in an XML-based language and are able to
+“import” schema components provided by Python packages.
+Since components are able to bind to conversion functions provided by
+Python code in the package (or elsewhere), configuration objects can
+be arbitrarily complex, with values that have been verified against
+arbitrary constraints.
+This makes it easy for applications to separate configuration support
+from configuration loading even with configuration data being defined
+and consumed by a wide range of separate packages.
+
+Reference documentation is available at https://zconfig.readthedocs.io
diff --git a/python/python3-ZConfig/python3-ZConfig.SlackBuild b/python/python3-ZConfig/python3-ZConfig.SlackBuild
new file mode 100644
index 0000000000..42efe8023f
--- /dev/null
+++ b/python/python3-ZConfig/python3-ZConfig.SlackBuild
@@ -0,0 +1,74 @@
+#!/bin/bash
+
+# Slackware build script for python3-ZConfig
+
+# Copyright 2023 Yth | Pont-en-Royans, France | yth@ythogtha.org
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-ZConfig
+SRCNAM=${PRGNAM#python3-*}
+VERSION=${VERSION:-4.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.?z*
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) -exec chmod 755 {} \; -o \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a [A-Z][A-Z]* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-ZConfig/python3-ZConfig.info b/python/python3-ZConfig/python3-ZConfig.info
new file mode 100644
index 0000000000..f338c0ce30
--- /dev/null
+++ b/python/python3-ZConfig/python3-ZConfig.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-ZConfig"
+VERSION="4.0"
+HOMEPAGE="https://github.com/zopefoundation/ZConfig/"
+DOWNLOAD="https://pypi.python.org/packages/source/Z/ZConfig/ZConfig-4.0.tar.gz"
+MD5SUM="10b37b49d50a5006a7135cb086b72184"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/python3-ZConfig/slack-desc b/python/python3-ZConfig/slack-desc
new file mode 100644
index 0000000000..0636ad7252
--- /dev/null
+++ b/python/python3-ZConfig/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-ZConfig: python3-ZConfig (Structured Configuration Library)
+python3-ZConfig:
+python3-ZConfig: ZConfig is a configuration library intended for general use.
+python3-ZConfig: It supports a hierarchical schema-driven configuration model that
+python3-ZConfig: allows a schema to specify data conversion routines written in Python
+python3-ZConfig: ZConfig's model is very different from the model supported by the
+python3-ZConfig: ConfigParser module found in Python's standard library, and is more
+python3-ZConfig: suitable to configuration-intensive applications.
+python3-ZConfig:
+python3-ZConfig: Documentation is available at https://zconfig.readthedocs.io
+python3-ZConfig: