summaryrefslogtreecommitdiffstats
path: root/python/python2-yenc
diff options
context:
space:
mode:
author Dave Woodfall2021-05-06 18:11:48 +0200
committer Willy Sudiarto Raharjo2021-05-07 20:41:53 +0200
commit73ea7ad7aa9bfa159532e6d993e5c84638394454 (patch)
tree1c784f94bf87204c2f58d48c800abb647e1a4185 /python/python2-yenc
parent289662417467d15824a2959e7d517df764c81f71 (diff)
downloadslackbuilds-73ea7ad7aa9bfa159532e6d993e5c84638394454.tar.gz
python/python-yenc: Renamed python2-yenc.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python2-yenc')
-rw-r--r--python/python2-yenc/README9
-rw-r--r--python/python2-yenc/python2-yenc.SlackBuild73
-rw-r--r--python/python2-yenc/python2-yenc.info10
-rw-r--r--python/python2-yenc/slack-desc19
4 files changed, 111 insertions, 0 deletions
diff --git a/python/python2-yenc/README b/python/python2-yenc/README
new file mode 100644
index 0000000000..59ddd5e880
--- /dev/null
+++ b/python/python2-yenc/README
@@ -0,0 +1,9 @@
+yEnc - a raw encoding/decoding module for Python
+
+This a fairly simple module, it provide only raw yEnc encoding/decoding
+with builitin crc32 calculation.
+
+Header parsing, checkings and yenc formatting are left to you (see
+examples directory for possible implementations). The interface was
+originally intended to be similar to the uu module from Python standard
+library.
diff --git a/python/python2-yenc/python2-yenc.SlackBuild b/python/python2-yenc/python2-yenc.SlackBuild
new file mode 100644
index 0000000000..5bce68003b
--- /dev/null
+++ b/python/python2-yenc/python2-yenc.SlackBuild
@@ -0,0 +1,73 @@
+#!/bin/sh
+
+# Slackware build script for python-yenc
+
+# Written by powtrix (@gmail.com)
+
+PRGNAM=python2-yenc
+VERSION=${VERSION:-0.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM=yenc
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {}\; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python2 setup.py install --root=$PKG
+
+rm -f $PKG/usr/lib${LIBDIRSUFFIX}/python2.6/site-packages/yenc-0.3-py2.6.egg-info
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGES COPYING README TODO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python2-yenc/python2-yenc.info b/python/python2-yenc/python2-yenc.info
new file mode 100644
index 0000000000..d1907377c5
--- /dev/null
+++ b/python/python2-yenc/python2-yenc.info
@@ -0,0 +1,10 @@
+PRGNAM="python2-yenc"
+VERSION="0.3"
+HOMEPAGE="https://sabnzbd.org/"
+DOWNLOAD="http://ponce.cc/slackware/sources/repo/yenc-0.3.tar.gz"
+MD5SUM="7b3edd32db6c1ce566ad550e3de64c83"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="powtrix"
+EMAIL="powtrix@gmail.com"
diff --git a/python/python2-yenc/slack-desc b/python/python2-yenc/slack-desc
new file mode 100644
index 0000000000..486c84b348
--- /dev/null
+++ b/python/python2-yenc/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-yenc: python2-yenc (raw encoding/decoding module for python)
+python2-yenc:
+python2-yenc: This a fairly simple module, it provide only raw yEnc
+python2-yenc: encoding/decoding with builtin crc32 calculation.
+python2-yenc:
+python2-yenc: Header parsing, checkings and yenc formatting are left to you
+python2-yenc: (see examples directory for possible implementations).
+python2-yenc: The interface originally intended to be similar to the uu
+python2-yenc: module from Python standard library.
+python2-yenc:
+python2-yenc: