summaryrefslogtreecommitdiffstats
path: root/python/python2-cssselect
diff options
context:
space:
mode:
author Jeremy Hansen2024-02-17 02:33:13 +0100
committer Willy Sudiarto Raharjo2024-02-17 02:40:10 +0100
commite19486a933a9d571a7380a3abdc23981a82e1048 (patch)
tree651cd35dda4561347828a940d826b4023712655c /python/python2-cssselect
parent7ce7500e6656d17e0d505bf6c36825577830fd88 (diff)
downloadslackbuilds-e19486a933a9d571a7380a3abdc23981a82e1048.tar.gz
python/python2-cssselect: Added (Python2 of cssselect).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python2-cssselect')
-rw-r--r--python/python2-cssselect/README14
-rw-r--r--python/python2-cssselect/python2-cssselect.SlackBuild80
-rw-r--r--python/python2-cssselect/python2-cssselect.info10
-rw-r--r--python/python2-cssselect/slack-desc19
4 files changed, 123 insertions, 0 deletions
diff --git a/python/python2-cssselect/README b/python/python2-cssselect/README
new file mode 100644
index 0000000000..c6355a81ce
--- /dev/null
+++ b/python/python2-cssselect/README
@@ -0,0 +1,14 @@
+python2-cssselect (CSS Selectors for Python)
+
+cssselect is a BSD-licensed Python library to parse CSS3 selectors
+and translate them to XPath 1.0 expressions.
+
+XPath 1.0 expressions can be used in lxml or another XPath engine
+to find the matching elements in an XML or HTML document.
+
+Note: This can coexist with python3-cssselect without issue.
+
+Also note: This has a circular optional dependency with lxml. If
+desired, rebuild this after installing lxml.
+
+Final note: This is the last version supporting python2.
diff --git a/python/python2-cssselect/python2-cssselect.SlackBuild b/python/python2-cssselect/python2-cssselect.SlackBuild
new file mode 100644
index 0000000000..6066534ec9
--- /dev/null
+++ b/python/python2-cssselect/python2-cssselect.SlackBuild
@@ -0,0 +1,80 @@
+#!/bin/bash
+
+# Slackware build script for python2-cssselect
+
+# Copyright 2024 Jeremy Hansen <jebrhansen+SBo@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python2-cssselect
+VERSION=${VERSION:-1.1.0}
+SRCNAM=${SRCNAM:-cssselect}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python2 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS CHANGES LICENSE README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python2-cssselect/python2-cssselect.info b/python/python2-cssselect/python2-cssselect.info
new file mode 100644
index 0000000000..1ac65e4823
--- /dev/null
+++ b/python/python2-cssselect/python2-cssselect.info
@@ -0,0 +1,10 @@
+PRGNAM="python2-cssselect"
+VERSION="1.1.0"
+HOMEPAGE="https://cssselect.readthedocs.io/"
+DOWNLOAD="https://github.com/scrapy/cssselect/archive/refs/tags/v1.1.0/cssselect-1.1.0.tar.gz"
+MD5SUM="bd0b6623c918704ee32f1cd750cc93bb"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Jeremy Hansen"
+EMAIL="jebrhansen+SBo@gmail.com"
diff --git a/python/python2-cssselect/slack-desc b/python/python2-cssselect/slack-desc
new file mode 100644
index 0000000000..cafc5f131a
--- /dev/null
+++ b/python/python2-cssselect/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-cssselect: python2-cssselect (CSS Selectors for Python)
+python2-cssselect:
+python2-cssselect: cssselect is a BSD-licensed Python library to parse CSS3 selectors
+python2-cssselect: and translate them to XPath 1.0 expressions.
+python2-cssselect:
+python2-cssselect: XPath 1.0 expressions can be used in lxml or another XPath engine
+python2-cssselect: to find the matching elements in an XML or HTML document.
+python2-cssselect:
+python2-cssselect: HOMEPAGE: https://cssselect.readthedocs.io/
+python2-cssselect:
+python2-cssselect: