summaryrefslogtreecommitdiffstats
path: root/python/python-twitter
diff options
context:
space:
mode:
author Robby Workman2011-03-16 07:13:49 +0100
committer Robby Workman2011-03-20 18:33:01 +0100
commit7a1b4848a3d34a263544fadf08178c91c12fbad0 (patch)
tree8987d0fc908e371dfa87445425f59c7514075b37 /python/python-twitter
parent987d45e99a299c3b24418b2976e8ec9d5f3bf404 (diff)
downloadslackbuilds-7a1b4848a3d34a263544fadf08178c91c12fbad0.tar.gz
python/*: Moved a lot of Python stuff here
The criteria for whether something "belongs" in Development or Libraries or Python or ... is admittedly arbitrary. As a general rule, if it could be either Libraries or Python, it's Python. Otherwise, pick one and we'll go from there... Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python/python-twitter')
-rw-r--r--python/python-twitter/README8
-rw-r--r--python/python-twitter/python-twitter.SlackBuild56
-rw-r--r--python/python-twitter/python-twitter.info10
-rw-r--r--python/python-twitter/slack-desc19
4 files changed, 93 insertions, 0 deletions
diff --git a/python/python-twitter/README b/python/python-twitter/README
new file mode 100644
index 0000000000..5d2d398bb1
--- /dev/null
+++ b/python/python-twitter/README
@@ -0,0 +1,8 @@
+This library provides a pure python interface for the Twitter API.
+
+Twitter (http://twitter.com) provides a service that allows people
+to connect via the web, IM, and SMS. Twitter exposes a web services
+API (http://twitter.com/help/api) and this library is intended to
+make it even easier for python programmers to use.
+
+This requires simplejson.
diff --git a/python/python-twitter/python-twitter.SlackBuild b/python/python-twitter/python-twitter.SlackBuild
new file mode 100644
index 0000000000..f6a6c30727
--- /dev/null
+++ b/python/python-twitter/python-twitter.SlackBuild
@@ -0,0 +1,56 @@
+#!/bin/sh
+
+# Slackware build script for python-twitter
+# Written by Steven Pledger <piratesmack@ymail.com>
+
+PRGNAM=python-twitter
+VERSION=${VERSION:-0.6}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGES COPYING LICENSE NOTICE README doc/* examples \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-twitter/python-twitter.info b/python/python-twitter/python-twitter.info
new file mode 100644
index 0000000000..9a8f5ff289
--- /dev/null
+++ b/python/python-twitter/python-twitter.info
@@ -0,0 +1,10 @@
+PRGNAM="python-twitter"
+VERSION="0.6"
+HOMEPAGE="http://code.google.com/p/python-twitter/"
+DOWNLOAD="http://python-twitter.googlecode.com/files/python-twitter-0.6.tar.gz"
+MD5SUM="e1f5c50c60c74944d29ce28178972b95"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Steven Pledger"
+EMAIL="piratesmack@ymail.com"
+APPROVED="rworkman"
diff --git a/python/python-twitter/slack-desc b/python/python-twitter/slack-desc
new file mode 100644
index 0000000000..b277876756
--- /dev/null
+++ b/python/python-twitter/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+python-twitter: python-twitter (python wrapper around the Twitter API)
+python-twitter:
+python-twitter: This library provides a pure python interface for the Twitter API.
+python-twitter:
+python-twitter: Homepage: http://code.google.com/p/python-twitter/
+python-twitter:
+python-twitter:
+python-twitter:
+python-twitter:
+python-twitter:
+python-twitter: