summaryrefslogtreecommitdiffstats
path: root/python/python-twitter
diff options
context:
space:
mode:
author Dimitris Zlatanidis2016-10-24 20:38:40 +0200
committer Willy Sudiarto Raharjo2016-10-29 01:58:15 +0200
commit7fd16b2b6f07ebeef539b8c03bff02c733190ecd (patch)
tree0928f6bfd3e8faca345a26e966a8d5f3923c7b14 /python/python-twitter
parent56c1cf6848a75865409dfd983c4281098f13d959 (diff)
downloadslackbuilds-7fd16b2b6f07ebeef539b8c03bff02c733190ecd.tar.gz
python/python-twitter: Updated for version 3.1.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'python/python-twitter')
-rw-r--r--python/python-twitter/README4
-rw-r--r--python/python-twitter/python-twitter.SlackBuild14
-rw-r--r--python/python-twitter/python-twitter.info8
3 files changed, 13 insertions, 13 deletions
diff --git a/python/python-twitter/README b/python/python-twitter/README
index e27efcffb2..547d66b606 100644
--- a/python/python-twitter/README
+++ b/python/python-twitter/README
@@ -1,6 +1,6 @@
This library provides a pure python interface for the Twitter API.
Twitter (http://twitter.com) provides a service that allows people
-to connect via the web, IM, and SMS. Twitter exposes a web services
-API (http://twitter.com/help/api) and this library is intended to
+to connect via the web, IM, and SMS. Twitter exposes a web services
+API (http://twitter.com/help/api) and this library is intended to
make it even easier for python programmers to use.
diff --git a/python/python-twitter/python-twitter.SlackBuild b/python/python-twitter/python-twitter.SlackBuild
index 8b06dbe00f..c367ce55b5 100644
--- a/python/python-twitter/python-twitter.SlackBuild
+++ b/python/python-twitter/python-twitter.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-twitter
# Written by Steven Pledger <piratesmack@ymail.com>
-# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,13 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=python-twitter
-VERSION=${VERSION:-2.2}
+VERSION=${VERSION:-3.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -50,10 +50,10 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
diff --git a/python/python-twitter/python-twitter.info b/python/python-twitter/python-twitter.info
index c21e8a6457..730efadc26 100644
--- a/python/python-twitter/python-twitter.info
+++ b/python/python-twitter/python-twitter.info
@@ -1,10 +1,10 @@
PRGNAM="python-twitter"
-VERSION="2.2"
+VERSION="3.1"
HOMEPAGE="https://github.com/bear/python-twitter"
-DOWNLOAD="https://pypi.python.org/packages/source/p/python-twitter/python-twitter-2.2.tar.gz"
-MD5SUM="eab697b3a9bc6bf3432d09a489f4ed8b"
+DOWNLOAD="https://pypi.python.org/packages/96/69/53b87d2b717a669eb8f46d6e1d180d0a691f3d303631ca6be80f9d036a2a/python-twitter-3.1.tar.gz"
+MD5SUM="2e00d057a22db298709f768a96cc88ef"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="simplejson requests-oauthlib"
+REQUIRES="python-future requests-oauthlib"
MAINTAINER="Dimitris Zlatanidis"
EMAIL="d.zlatanidis@gmail.com"