summaryrefslogtreecommitdiffstats
path: root/python/python-pcapy/python-pcapy.SlackBuild
diff options
context:
space:
mode:
author Brenton Earl2018-04-11 23:49:13 +0200
committer Willy Sudiarto Raharjo2018-04-14 02:06:28 +0200
commit3eb8b3c4ddf0de9a88316024fad5a60ea238df42 (patch)
tree8e92b90153708e5e8820b1821b5d86e223cbf3e3 /python/python-pcapy/python-pcapy.SlackBuild
parent088932d279c72e6152f735ed8510401a2b4bb85e (diff)
downloadslackbuilds-3eb8b3c4ddf0de9a88316024fad5a60ea238df42.tar.gz
python/python-pcapy: Updated for version 0.11.3.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python/python-pcapy/python-pcapy.SlackBuild')
-rw-r--r--python/python-pcapy/python-pcapy.SlackBuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/python/python-pcapy/python-pcapy.SlackBuild b/python/python-pcapy/python-pcapy.SlackBuild
index 9cae5a4cad..f27972bf09 100644
--- a/python/python-pcapy/python-pcapy.SlackBuild
+++ b/python/python-pcapy/python-pcapy.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=python-pcapy
SRCNAM=pcapy
-VERSION=${VERSION:-0.11.1}
+VERSION=${VERSION:-0.11.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -76,6 +76,11 @@ patch -p1 --verbose < $CWD/no-auto-docs-setup.py.diff
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true