summaryrefslogtreecommitdiffstats
path: root/python/python-distutils-extra/python-distutils-extra.SlackBuild
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2016-03-26 09:33:32 +0100
committer David Spencer2016-03-31 13:49:19 +0200
commite8ce25604731717a14cb7eac69aa5c87ff3d1548 (patch)
tree218a40e1bb941fec4eccce47f54c380ba95c4018 /python/python-distutils-extra/python-distutils-extra.SlackBuild
parent9a89a48f5aaf9b10ed18bcf8772bba2816cc0440 (diff)
downloadslackbuilds-e8ce25604731717a14cb7eac69aa5c87ff3d1548.tar.gz
python/python-distutils-extra: Updated for version 2.39.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python-distutils-extra/python-distutils-extra.SlackBuild')
-rw-r--r--python/python-distutils-extra/python-distutils-extra.SlackBuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/python/python-distutils-extra/python-distutils-extra.SlackBuild b/python/python-distutils-extra/python-distutils-extra.SlackBuild
index 22d487c34a..1109d09f63 100644
--- a/python/python-distutils-extra/python-distutils-extra.SlackBuild
+++ b/python/python-distutils-extra/python-distutils-extra.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=python-distutils-extra
-VERSION=${VERSION:-2.38}
+VERSION=${VERSION:-2.39}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -50,14 +50,14 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION