summaryrefslogtreecommitdiffstats
path: root/python/python-cached-property
diff options
context:
space:
mode:
author Audrius Kažukauskas2017-06-11 20:15:17 +0200
committer Willy Sudiarto Raharjo2017-06-15 13:35:52 +0200
commit69cb970b38e6e98617c9a8e1f0b1df6f306453f2 (patch)
treee853d471fc1852108ddd219e2cb4c8ef9a506456 /python/python-cached-property
parent2d609653307e5826d566b3234409c563d5ca65cc (diff)
downloadslackbuilds-69cb970b38e6e98617c9a8e1f0b1df6f306453f2.tar.gz
python/python-cached-property: Added (caching properties decorator).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python/python-cached-property')
-rw-r--r--python/python-cached-property/README1
-rw-r--r--python/python-cached-property/python-cached-property.SlackBuild70
-rw-r--r--python/python-cached-property/python-cached-property.info10
-rw-r--r--python/python-cached-property/slack-desc19
4 files changed, 100 insertions, 0 deletions
diff --git a/python/python-cached-property/README b/python/python-cached-property/README
new file mode 100644
index 0000000000..f5f4d6f535
--- /dev/null
+++ b/python/python-cached-property/README
@@ -0,0 +1 @@
+A Python decorator for caching properties in classes.
diff --git a/python/python-cached-property/python-cached-property.SlackBuild b/python/python-cached-property/python-cached-property.SlackBuild
new file mode 100644
index 0000000000..fbadf92fad
--- /dev/null
+++ b/python/python-cached-property/python-cached-property.SlackBuild
@@ -0,0 +1,70 @@
+#!/bin/sh
+
+# Slackware build script for python-cached-property
+
+# Copyright 2017 Audrius Kažukauskas <audrius@neutrino.lt>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-cached-property
+VERSION=${VERSION:-1.3.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM="$(printf $PRGNAM | cut -d- -f2-)"
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS.rst HISTORY.rst LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-cached-property/python-cached-property.info b/python/python-cached-property/python-cached-property.info
new file mode 100644
index 0000000000..c8ee7a77e0
--- /dev/null
+++ b/python/python-cached-property/python-cached-property.info
@@ -0,0 +1,10 @@
+PRGNAM="python-cached-property"
+VERSION="1.3.0"
+HOMEPAGE="https://github.com/pydanny/cached-property"
+DOWNLOAD="https://pypi.python.org/packages/ae/02/09b905981aefb99c97ad53ac1cc0a90f02c1457a549eae98d87e8e6f2d7e/cached-property-1.3.0.tar.gz"
+MD5SUM="4a6039f7418007275505e355359396a8"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Audrius Kažukauskas"
+EMAIL="audrius@neutrino.lt"
diff --git a/python/python-cached-property/slack-desc b/python/python-cached-property/slack-desc
new file mode 100644
index 0000000000..eeb010102d
--- /dev/null
+++ b/python/python-cached-property/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-cached-property: python-cached-property (decorator for caching properties in classes)
+python-cached-property:
+python-cached-property: Homepage: https://github.com/pydanny/cached-property
+python-cached-property:
+python-cached-property:
+python-cached-property:
+python-cached-property:
+python-cached-property:
+python-cached-property:
+python-cached-property:
+python-cached-property: