summaryrefslogtreecommitdiffstats
path: root/python/pyOpenSSL/pyOpenSSL.SlackBuild
diff options
context:
space:
mode:
author Markus Reichelt2014-10-04 18:45:31 +0200
committer Willy Sudiarto Raharjo2014-10-04 18:45:31 +0200
commit7bad136728cb93637bd834acf3508ec4abbeeb2b (patch)
tree35cc92960c25d1074c4ad0fc8cc4628aeae609f1 /python/pyOpenSSL/pyOpenSSL.SlackBuild
parent248ca0150500fd8cb1ed485fe28d66a8ccc35e7d (diff)
downloadslackbuilds-7bad136728cb93637bd834acf3508ec4abbeeb2b.tar.gz
python/pyOpenSSL: Updated for version 0.14.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/pyOpenSSL/pyOpenSSL.SlackBuild')
-rw-r--r--python/pyOpenSSL/pyOpenSSL.SlackBuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/python/pyOpenSSL/pyOpenSSL.SlackBuild b/python/pyOpenSSL/pyOpenSSL.SlackBuild
index e1d940ccbf..a123eb4d88 100644
--- a/python/pyOpenSSL/pyOpenSSL.SlackBuild
+++ b/python/pyOpenSSL/pyOpenSSL.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for pyOpenSSL.
#
# Copyright 2010-2011 Marco Bonetti <sid77@slackware.it>
-# Copyright 2012 Markus Reichelt, Aachen, DE
+# Copyright 2012-2014 Markus Reichelt, Stolberg (Rhld.), DE
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -27,7 +27,7 @@
# Now maintained by Markus Reichelt <slackbuilds@mareichelt.de>, 0xCCEEF115
PRGNAM=pyOpenSSL
-VERSION=${VERSION:-0.13.1}
+VERSION=${VERSION:-0.14}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -60,11 +60,11 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION