summaryrefslogtreecommitdiffstats
path: root/python/pyOpenSSL/pyOpenSSL.SlackBuild
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2013-11-13 13:20:35 +0100
committer Robby Workman2013-11-13 18:19:03 +0100
commit4687c9b5268930440b12bfcca420ad432f410cbc (patch)
tree3f2b2413dcbb236e4f116019182d140a14926402 /python/pyOpenSSL/pyOpenSSL.SlackBuild
parent174f8086cf91ec67bbcfbdad96af80c705f90c65 (diff)
downloadslackbuilds-4687c9b5268930440b12bfcca420ad432f410cbc.tar.gz
python/pyOpenSSL: Updated for version 0.13.1
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/pyOpenSSL/pyOpenSSL.SlackBuild')
-rw-r--r--python/pyOpenSSL/pyOpenSSL.SlackBuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/python/pyOpenSSL/pyOpenSSL.SlackBuild b/python/pyOpenSSL/pyOpenSSL.SlackBuild
index 578a0afa25..e1d940ccbf 100644
--- a/python/pyOpenSSL/pyOpenSSL.SlackBuild
+++ b/python/pyOpenSSL/pyOpenSSL.SlackBuild
@@ -27,7 +27,7 @@
# Now maintained by Markus Reichelt <slackbuilds@mareichelt.de>, 0xCCEEF115
PRGNAM=pyOpenSSL
-VERSION=0.13
+VERSION=${VERSION:-0.13.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -56,11 +56,11 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG