summaryrefslogtreecommitdiffstats
path: root/python/pkginfo/pkginfo.SlackBuild
diff options
context:
space:
mode:
author Dimitris Zlatanidis2016-11-05 04:47:11 +0100
committer David Spencer2016-11-11 21:36:30 +0100
commit531d5ba42e3a3fbe4d8a91fed28bd398f4b43fc3 (patch)
treef1c349298c091b72d76b248d13cf4fc201fc5e2f /python/pkginfo/pkginfo.SlackBuild
parentc72255fa9969cc95996fc6f37de6966f5140c075 (diff)
downloadslackbuilds-531d5ba42e3a3fbe4d8a91fed28bd398f4b43fc3.tar.gz
python/pkginfo: Updated for version 1.4.0.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'python/pkginfo/pkginfo.SlackBuild')
-rw-r--r--python/pkginfo/pkginfo.SlackBuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/python/pkginfo/pkginfo.SlackBuild b/python/pkginfo/pkginfo.SlackBuild
index 7953c09196..f62c766324 100644
--- a/python/pkginfo/pkginfo.SlackBuild
+++ b/python/pkginfo/pkginfo.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pkginfo
-VERSION=${VERSION:-1.3.2}
+VERSION=${VERSION:-1.4.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,13 +69,16 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# fix build
+patch -p1 < $CWD/setup.patch
+
python setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.txt CHANGES.txt TODO.txt PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.txt PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install