summaryrefslogtreecommitdiffstats
path: root/python/p4python
diff options
context:
space:
mode:
author Robby Workman2011-03-16 07:13:49 +0100
committer Robby Workman2011-03-20 18:33:01 +0100
commit7a1b4848a3d34a263544fadf08178c91c12fbad0 (patch)
tree8987d0fc908e371dfa87445425f59c7514075b37 /python/p4python
parent987d45e99a299c3b24418b2976e8ec9d5f3bf404 (diff)
downloadslackbuilds-7a1b4848a3d34a263544fadf08178c91c12fbad0.tar.gz
python/*: Moved a lot of Python stuff here
The criteria for whether something "belongs" in Development or Libraries or Python or ... is admittedly arbitrary. As a general rule, if it could be either Libraries or Python, it's Python. Otherwise, pick one and we'll go from there... Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'python/p4python')
-rw-r--r--python/p4python/README6
-rw-r--r--python/p4python/p4python.SlackBuild71
-rw-r--r--python/p4python/p4python.info10
-rw-r--r--python/p4python/slack-desc19
4 files changed, 106 insertions, 0 deletions
diff --git a/python/p4python/README b/python/p4python/README
new file mode 100644
index 0000000000..0e9f74ecd5
--- /dev/null
+++ b/python/p4python/README
@@ -0,0 +1,6 @@
+Perforce is the fast SCM system at www.perforce.com.
+This package provides a simple interface from Python wrapping the
+Perforce C++ API to gain performance and ease of coding.
+Similar to interfaces available for Ruby and Perl.
+
+This requires p4api.
diff --git a/python/p4python/p4python.SlackBuild b/python/p4python/p4python.SlackBuild
new file mode 100644
index 0000000000..dfb79e9f4d
--- /dev/null
+++ b/python/p4python/p4python.SlackBuild
@@ -0,0 +1,71 @@
+#!/bin/sh
+
+# SlackBuild for p4python, Andy Bailey <bailey@akamai.com
+
+LOCALVER=`tar tf p4python.tgz 2> /dev/null | head -1 | cut -d- -f 2 | cut -d/ -f1`
+PRGNAM=p4python
+VERSION=${VERSION:-$LOCALVER}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf P4Python-$VERSION
+tar xvf $CWD/$PRGNAM.tgz
+cd P4Python-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+echo "[p4python_config]" > setup.cfg
+echo "p4_api=/usr/lib$LIBDIRSUFFIX/p4" >> setup.cfg
+python setup.py install --root=$PKG
+
+# Strip binaries and libraries.
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE.txt README.txt RELNOTES.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/p4python/p4python.info b/python/p4python/p4python.info
new file mode 100644
index 0000000000..08d3de716f
--- /dev/null
+++ b/python/p4python/p4python.info
@@ -0,0 +1,10 @@
+PRGNAM="p4python"
+VERSION="2010.1"
+HOMEPAGE="http://www.perforce.com/perforce/loadsupp.html"
+DOWNLOAD="ftp://ftp.perforce.com/perforce/r10.1/bin.tools/p4python.tgz"
+MD5SUM="d9af612a506da5f6bc655410a67446e1"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Andy Bailey"
+EMAIL="bailey@akamai.com"
+APPROVED="dsomero"
diff --git a/python/p4python/slack-desc b/python/p4python/slack-desc
new file mode 100644
index 0000000000..bd81786838
--- /dev/null
+++ b/python/p4python/slack-desc
@@ -0,0 +1,19 @@
+ # HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+p4python: p4python (python bindings for Perforce api)
+p4python:
+p4python: Perforce is the fast SCM system at www.perforce.com.
+p4python: This package provides a simple interface from Python wrapping the
+p4python: Perforce C++ API to gain performance and ease of coding.
+p4python: Similar to interfaces available for Ruby and Perl.
+p4python:
+p4python:
+p4python:
+p4python:
+p4python: \ No newline at end of file