summaryrefslogtreecommitdiffstats
path: root/python/httplib2/httplib2.SlackBuild
diff options
context:
space:
mode:
author Larry Hajali2014-02-10 16:17:10 +0100
committer Erik Hanson2014-02-11 19:14:56 +0100
commit89e6f2c4c43bb932c44fcd97fd7db45b1dce13fc (patch)
tree9ddc53fd384d967ee355d7dc11a83e6ce7c25ebd /python/httplib2/httplib2.SlackBuild
parent8f3e79a5b786d141bbdf37543bd1bfc5b747a91b (diff)
downloadslackbuilds-89e6f2c4c43bb932c44fcd97fd7db45b1dce13fc.tar.gz
python/httplib2: Added patches for ssl.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'python/httplib2/httplib2.SlackBuild')
-rw-r--r--python/httplib2/httplib2.SlackBuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/python/httplib2/httplib2.SlackBuild b/python/httplib2/httplib2.SlackBuild
index c4fc145f20..d9e910a83c 100644
--- a/python/httplib2/httplib2.SlackBuild
+++ b/python/httplib2/httplib2.SlackBuild
@@ -23,7 +23,7 @@
PRGNAM=httplib2
VERSION=${VERSION:-0.8}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -53,9 +53,12 @@ else
LIBDIRSUFFIX=""
fi
+PYTHON=python
+[ "${PYTHON3:-no}" = "yes" ] && PYTHON=python3
+
DOCS="CHANGELOG README"
-set -e
+set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -70,7 +73,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+# Fix ssl hostname mismatch.
+patch -p1 < $CWD/ssl_hostname.diff
+# Use system ca-certificates.crt.
+patch -p1 < $CWD/use_system_cacerts.patch
+
+$PYTHON setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true