summaryrefslogtreecommitdiffstats
path: root/python/functools-lru-cache
diff options
context:
space:
mode:
author Serban Udrea2017-05-01 02:45:52 +0200
committer Willy Sudiarto Raharjo2017-05-01 02:45:52 +0200
commit1b73a1854dc61af7f6c536fbd7afdec877106fb3 (patch)
tree848ef610a971fac88797775eed4cb7ef4f5e186c /python/functools-lru-cache
parentf37363d25a127b070979d94ada634e3b738f3a66 (diff)
downloadslackbuilds-1b73a1854dc61af7f6c536fbd7afdec877106fb3.tar.gz
python/functools-lru-cache: Added (Python module).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/functools-lru-cache')
-rw-r--r--python/functools-lru-cache/README2
-rw-r--r--python/functools-lru-cache/functools-lru-cache.SlackBuild71
-rw-r--r--python/functools-lru-cache/functools-lru-cache.info10
-rw-r--r--python/functools-lru-cache/slack-desc19
4 files changed, 102 insertions, 0 deletions
diff --git a/python/functools-lru-cache/README b/python/functools-lru-cache/README
new file mode 100644
index 0000000000..037d48ee75
--- /dev/null
+++ b/python/functools-lru-cache/README
@@ -0,0 +1,2 @@
+This is a backport of functools.lru_cache from Python 3.3 as published
+at ActiveState.
diff --git a/python/functools-lru-cache/functools-lru-cache.SlackBuild b/python/functools-lru-cache/functools-lru-cache.SlackBuild
new file mode 100644
index 0000000000..98636659ec
--- /dev/null
+++ b/python/functools-lru-cache/functools-lru-cache.SlackBuild
@@ -0,0 +1,71 @@
+#!/bin/sh
+
+# Slackware build script for functools-lru-cache
+
+# Copyright 2017 Serban Udrea <s.udrea@gsi.de>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=functools-lru-cache
+SRCNAM="backports.functools_lru_cache"
+VERSION=${VERSION:-1.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar -xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+mkdir -p ${PKG}/usr/doc/$PRGNAM-$VERSION
+rm -rf ${PKG}/usr/share
+
+cp -a PKG-INFO CHANGES.rst README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/functools-lru-cache/functools-lru-cache.info b/python/functools-lru-cache/functools-lru-cache.info
new file mode 100644
index 0000000000..ccc60412db
--- /dev/null
+++ b/python/functools-lru-cache/functools-lru-cache.info
@@ -0,0 +1,10 @@
+PRGNAM="functools-lru-cache"
+VERSION="1.3"
+HOMEPAGE="http://code.activestate.com/recipes/578078/"
+DOWNLOAD="https://pypi.python.org/packages/00/9c/70c865c629d406531d05f46a5c5f68874f186bcc0424ed3bd7cbe54bfe7d/backports.functools_lru_cache-1.3.tar.gz"
+MD5SUM="b26a223250bd24ea2e0ad6ce47b19084"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Serban Udrea"
+EMAIL="S.Udrea@gsi.de"
diff --git a/python/functools-lru-cache/slack-desc b/python/functools-lru-cache/slack-desc
new file mode 100644
index 0000000000..b57f97ad5b
--- /dev/null
+++ b/python/functools-lru-cache/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+functools-lru-cache: functools-lru-cache (backport of functools.lru_cache)
+functools-lru-cache:
+functools-lru-cache: This is a backport of functools.lru_cache from Python 3.3 as published
+functools-lru-cache: at ActiveState.
+functools-lru-cache:
+functools-lru-cache:
+functools-lru-cache:
+functools-lru-cache:
+functools-lru-cache:
+functools-lru-cache:
+functools-lru-cache: