summaryrefslogtreecommitdiffstats
path: root/python/feedparser/001_py37.diff
diff options
context:
space:
mode:
author Christoph Willing2019-06-26 09:12:43 +0200
committer Willy Sudiarto Raharjo2019-06-29 03:17:48 +0200
commita77e44b2ccd6aea42ec48a1e5f0196375d4bb690 (patch)
tree3d7fffcd59e0bc3950b9cb097dc373c71538887c /python/feedparser/001_py37.diff
parent6f309be790ab3a703370e092fb760fdf3ee897da (diff)
downloadslackbuilds-a77e44b2ccd6aea42ec48a1e5f0196375d4bb690.tar.gz
python/feedparser: Added python3 support
Signed-off-by: Christoph Willing <chris.willing@linux.com>
Diffstat (limited to 'python/feedparser/001_py37.diff')
-rw-r--r--python/feedparser/001_py37.diff23
1 files changed, 23 insertions, 0 deletions
diff --git a/python/feedparser/001_py37.diff b/python/feedparser/001_py37.diff
new file mode 100644
index 0000000000..5182a5b2b8
--- /dev/null
+++ b/python/feedparser/001_py37.diff
@@ -0,0 +1,23 @@
+--- setup.py.orig 2015-07-24 15:00:04.000000000 +1000
++++ setup.py 2019-06-24 21:34:06.883000000 +1000
+@@ -35,6 +35,9 @@
+ 'Programming Language :: Python :: 3.2',
+ 'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: 3.4',
++ 'Programming Language :: Python :: 3.5',
++ 'Programming Language :: Python :: 3.6',
++ 'Programming Language :: Python :: 3.7',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+ 'Topic :: Text Processing :: Markup :: XML',
+ ],
+--- feedparser/feedparser.py.orig 2015-07-24 15:00:04.000000000 +1000
++++ feedparser/feedparser.py 2019-06-24 22:15:09.636000000 +1000
+@@ -130,6 +130,8 @@
+ #ACCEPTABLE_URI_SCHEMES = ()
+
+ # ---------- required modules (should come with any Python distribution) ----------
++from __future__ import absolute_import, unicode_literals
++
+ import cgi
+ import codecs
+ import copy