summaryrefslogtreecommitdiffstats
path: root/python/cryptography
diff options
context:
space:
mode:
author Andrew Clemons2018-09-13 04:19:29 +0200
committer Willy Sudiarto Raharjo2018-11-17 12:32:39 +0100
commit75e1b2e63ebb1ea592f9647a788b634a338ff39f (patch)
tree332a3eef7c5c475c64f72d94086cd72de3c87f80 /python/cryptography
parent8bf496d58172e1c46b1e7ad66fef2c0098fad23d (diff)
downloadslackbuilds-75e1b2e63ebb1ea592f9647a788b634a338ff39f.tar.gz
python/cryptography: Add python3 support.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/cryptography')
-rw-r--r--python/cryptography/cryptography.SlackBuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/python/cryptography/cryptography.SlackBuild b/python/cryptography/cryptography.SlackBuild
index 1135b1dcf8..120640c210 100644
--- a/python/cryptography/cryptography.SlackBuild
+++ b/python/cryptography/cryptography.SlackBuild
@@ -73,6 +73,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true