summaryrefslogtreecommitdiffstats
path: root/python/coverage/coverage.SlackBuild
diff options
context:
space:
mode:
author Dimitris Zlatanidis2016-10-03 12:30:43 +0200
committer Willy Sudiarto Raharjo2016-10-08 03:07:20 +0200
commit80949a3dc4c141259fe1259ecf10dee9111dc134 (patch)
tree3abea79822d6d10c75882032579c4234f3be64d5 /python/coverage/coverage.SlackBuild
parent1193cfcf13ead8c03440b650327f8ad77716bd53 (diff)
downloadslackbuilds-80949a3dc4c141259fe1259ecf10dee9111dc134.tar.gz
python/coverage: Updated for version 4.2.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'python/coverage/coverage.SlackBuild')
-rw-r--r--python/coverage/coverage.SlackBuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/python/coverage/coverage.SlackBuild b/python/coverage/coverage.SlackBuild
index c06578b370..92e52c8b88 100644
--- a/python/coverage/coverage.SlackBuild
+++ b/python/coverage/coverage.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for coverage
-# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,13 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=coverage
-VERSION=${VERSION:-4.0a5}
+VERSION=${VERSION:-4.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -67,7 +67,7 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
@@ -75,7 +75,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.txt AUTHORS.txt CHANGES.txt PKG-INFO doc/*.rst \
+cp -a README.rst AUTHORS.txt CHANGES.rst PKG-INFO doc/*.rst \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild