summaryrefslogtreecommitdiffstats
path: root/python/cloudscraper
diff options
context:
space:
mode:
author Hunter Sezen2020-02-15 02:16:53 +0100
committer Willy Sudiarto Raharjo2020-02-15 02:16:53 +0100
commitba068cc1f321ec2223b82f53030b784a61ec5566 (patch)
tree6d56e77b60c782cfce5ed1c1597b8c6a473e22de /python/cloudscraper
parent9b89842eeb78d43ec185fdb5dc60f36c48f7296b (diff)
downloadslackbuilds-ba068cc1f321ec2223b82f53030b784a61ec5566.tar.gz
python/cloudscraper: Added (Python Module).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/cloudscraper')
-rw-r--r--python/cloudscraper/README6
-rw-r--r--python/cloudscraper/cloudscraper.SlackBuild68
-rw-r--r--python/cloudscraper/cloudscraper.info10
-rw-r--r--python/cloudscraper/slack-desc19
4 files changed, 103 insertions, 0 deletions
diff --git a/python/cloudscraper/README b/python/cloudscraper/README
new file mode 100644
index 0000000000..fda7ca3f57
--- /dev/null
+++ b/python/cloudscraper/README
@@ -0,0 +1,6 @@
+A simple Python module to bypass Cloudflare's anti-bot page (also known
+as "I'm Under Attack Mode", or IUAM), implemented with Requests.
+
+All of the dependencies require python3 support.
+
+Optional dependency: brotli
diff --git a/python/cloudscraper/cloudscraper.SlackBuild b/python/cloudscraper/cloudscraper.SlackBuild
new file mode 100644
index 0000000000..fa30a56da6
--- /dev/null
+++ b/python/cloudscraper/cloudscraper.SlackBuild
@@ -0,0 +1,68 @@
+#!/bin/sh
+
+# Slackware build script for cloudscraper
+
+# Copyright 2020 Hunter Sezen California, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=cloudscraper
+VERSION=${VERSION:-1.2.20}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -eu
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/cloudscraper/cloudscraper.info b/python/cloudscraper/cloudscraper.info
new file mode 100644
index 0000000000..36f12b31dd
--- /dev/null
+++ b/python/cloudscraper/cloudscraper.info
@@ -0,0 +1,10 @@
+PRGNAM="cloudscraper"
+VERSION="1.2.20"
+HOMEPAGE="https://github.com/VeNoMouS/cloudscraper"
+DOWNLOAD="https://github.com/VeNoMouS/cloudscraper/archive/1.2.20/cloudscraper-1.2.20.tar.gz"
+MD5SUM="1c48f66c34dc53588ef56d7e662cab67"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-certifi python-requests"
+MAINTAINER="Hunter Sezen"
+EMAIL="orbea@riseup.net"
diff --git a/python/cloudscraper/slack-desc b/python/cloudscraper/slack-desc
new file mode 100644
index 0000000000..988c19a289
--- /dev/null
+++ b/python/cloudscraper/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+cloudscraper: cloudscraper (Python module to bypass Cloudflare's anti-bot page)
+cloudscraper:
+cloudscraper: A simple Python module to bypass Cloudflare's anti-bot page (also
+cloudscraper: known as "I'm Under Attack Mode", or IUAM), implemented with Requests.
+cloudscraper:
+cloudscraper: Homepage: https://github.com/VeNoMouS/cloudscraper
+cloudscraper:
+cloudscraper:
+cloudscraper:
+cloudscraper:
+cloudscraper: