summaryrefslogtreecommitdiffstats
path: root/perl/perl-lwp-useragent-cached/no_test_requires.diff
diff options
context:
space:
mode:
author B. Watson2015-05-13 02:09:01 +0200
committer Willy Sudiarto Raharjo2015-05-13 02:09:01 +0200
commit8219eb57475366faf06e95c85235c12e11246060 (patch)
tree9d5b869ab5b84e13f2982f2173b479378dcc490f /perl/perl-lwp-useragent-cached/no_test_requires.diff
parent8f64f583fb761ac1c993563fe8882886b5acab2e (diff)
downloadslackbuilds-8219eb57475366faf06e95c85235c12e11246060.tar.gz
perl/perl-lwp-useragent-cached: Added (UserAgent caching mechanism).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'perl/perl-lwp-useragent-cached/no_test_requires.diff')
-rw-r--r--perl/perl-lwp-useragent-cached/no_test_requires.diff38
1 files changed, 38 insertions, 0 deletions
diff --git a/perl/perl-lwp-useragent-cached/no_test_requires.diff b/perl/perl-lwp-useragent-cached/no_test_requires.diff
new file mode 100644
index 0000000000..91f6f03ba6
--- /dev/null
+++ b/perl/perl-lwp-useragent-cached/no_test_requires.diff
@@ -0,0 +1,38 @@
+diff -Naur LWP-UserAgent-Cached-0.06/Makefile.PL LWP-UserAgent-Cached-0.06.patched/Makefile.PL
+--- LWP-UserAgent-Cached-0.06/Makefile.PL 2014-06-27 13:32:55.000000000 -0400
++++ LWP-UserAgent-Cached-0.06.patched/Makefile.PL 2015-05-12 18:40:40.000000000 -0400
+@@ -4,33 +4,7 @@
+ # See lib/ExtUtils/MakeMaker.pm for details of how to influence
+ # the contents of the Makefile that is written.
+
+-my %test_requires = (
+- 'Test::Mock::LWP::Dispatch' => 0.02,
+- 'File::Temp' => 0
+-);
+-
+-my $not_installed_test_modules = '';
+-while (my ($module, $ver) = each %test_requires) {
+-
+- eval "use $module $ver";
+- if ($@) {
+- $not_installed_test_modules .= "\t$module $ver\n";
+- }
+-}
+-
+-if ($not_installed_test_modules) {
+- my $choose = prompt(
+- "We need few optional additional modules to test this package on your system:\n".
+- $not_installed_test_modules.
+- "If you'll choose `n' this tests will be skipped.\n".
+- "Append this modules to installation queue?",
+- "y"
+- );
+-
+- if ($choose =~ /n/) {
+- %test_requires = ();
+- }
+-}
++my %test_requires = ();
+
+ $test_requires{'Test::More'} = 0.88;
+