summaryrefslogtreecommitdiffstats
path: root/perl/perl-libnet
diff options
context:
space:
mode:
author Matteo Bernardini2020-01-12 12:08:26 +0100
committer Matteo Bernardini2020-01-12 12:08:26 +0100
commit0c6fe367a7009c5bbabc3071f8cccc77a37859eb (patch)
treeac54688f55ad545306ad664b6b58a85e87de6768 /perl/perl-libnet
parent3066e0530b82d92e7856c44afb715f6fae0a5df0 (diff)
downloadslackbuilds-0c6fe367a7009c5bbabc3071f8cccc77a37859eb.tar.gz
20200112.1 global branch merge.current-20200112.1
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'perl/perl-libnet')
-rw-r--r--perl/perl-libnet/README3
-rw-r--r--perl/perl-libnet/libnet-3.08-Do-not-create-Net-libnet.cfg.patch43
-rw-r--r--perl/perl-libnet/perl-libnet.SlackBuild105
-rw-r--r--perl/perl-libnet/perl-libnet.info10
-rw-r--r--perl/perl-libnet/slack-desc19
5 files changed, 0 insertions, 180 deletions
diff --git a/perl/perl-libnet/README b/perl/perl-libnet/README
deleted file mode 100644
index 0b66c0e6c3..0000000000
--- a/perl/perl-libnet/README
+++ /dev/null
@@ -1,3 +0,0 @@
-libnet is a collection of Perl modules which provides a simple
-and consistent programming interface (API) to the client side
-of various protocols used in the internet community.
diff --git a/perl/perl-libnet/libnet-3.08-Do-not-create-Net-libnet.cfg.patch b/perl/perl-libnet/libnet-3.08-Do-not-create-Net-libnet.cfg.patch
deleted file mode 100644
index 911bc10fa8..0000000000
--- a/perl/perl-libnet/libnet-3.08-Do-not-create-Net-libnet.cfg.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From a40f2774eede8e65dd6128b45525ec88f469e031 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
-Date: Fri, 10 Jul 2015 13:02:00 +0200
-Subject: [PATCH 2/2] Do not create Net/libnet.cfg
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-I will remove the Net/libnet.cfg because:
-
-(1) it's content equals to default configuration hard-coded in the
-code
-(2) it's kind of configuration file we do not mark it as a configuration
-file, so it's overwritten on each update
-(3) it's loaded from directory based on Net::Config module location.
-I.e. core module will search it in core path, vendor module in vendor
-path and site module in site path.
-
-perl.spec does not provide it either.
-
-<https://bugzilla.redhat.com/show_bug.cgi?id=1238689>
-
-Signed-off-by: Petr Písař <ppisar@redhat.com>
----
- Makefile.PL | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/Makefile.PL b/Makefile.PL
-index 64d6959..25fc626 100644
---- a/Makefile.PL
-+++ b/Makefile.PL
-@@ -235,7 +235,7 @@ MAIN: {
- sub MY::post_initialize {
- my $self = shift;
-
-- return '' if $self->{PERL_CORE};
-+ return '';
-
- if (not -f $CfgFile) {
- my @args = qw(Configure);
---
-2.5.0
-
diff --git a/perl/perl-libnet/perl-libnet.SlackBuild b/perl/perl-libnet/perl-libnet.SlackBuild
deleted file mode 100644
index 5f4feddd26..0000000000
--- a/perl/perl-libnet/perl-libnet.SlackBuild
+++ /dev/null
@@ -1,105 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for perl-libnet
-
-# Copyright 2016-2017 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
-# Based on slackbuilds.org perl template.
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=perl-libnet
-VERSION=${VERSION:-3.11}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-SRCNAM=libnet
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-DOCS="Artistic Changes Copying LICENCE README"
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-patch -p1 < $CWD/libnet-3.08-Do-not-create-Net-libnet.cfg.patch
-
-echo | perl Makefile.PL \
- PREFIX=/usr \
- INSTALLDIRS=vendor \
- INSTALLVENDORMAN3DIR=/usr/man/man3
-make
-make test
-make install DESTDIR=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-find $PKG -name perllocal.pod -o -name ".packlist" -o -name "*.bs" | xargs rm -f || true
-
-find $PKG -depth -type d -empty -delete || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/perl/perl-libnet/perl-libnet.info b/perl/perl-libnet/perl-libnet.info
deleted file mode 100644
index b43abac717..0000000000
--- a/perl/perl-libnet/perl-libnet.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="perl-libnet"
-VERSION="3.11"
-HOMEPAGE="https://metacpan.org/release/libnet"
-DOWNLOAD="https://cpan.metacpan.org/authors/id/S/SH/SHAY/libnet-3.11.tar.gz"
-MD5SUM="f4fdfa0906bf2ad5ac3c74c3860eb029"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="perl-IO-Socket-SSL"
-MAINTAINER="Matteo Bernardini"
-EMAIL="ponce@slackbuilds.org"
diff --git a/perl/perl-libnet/slack-desc b/perl/perl-libnet/slack-desc
deleted file mode 100644
index faf8be5984..0000000000
--- a/perl/perl-libnet/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-perl-libnet: perl-libnet (perl net modules)
-perl-libnet:
-perl-libnet: libnet is a collection of Perl modules which provides a simple
-perl-libnet: and consistent programming interface (API) to the client side
-perl-libnet: of various protocols used in the internet community.
-perl-libnet:
-perl-libnet: homepage: https://metacpan.org/release/libnet
-perl-libnet:
-perl-libnet:
-perl-libnet:
-perl-libnet: