summaryrefslogtreecommitdiffstats
path: root/office
diff options
context:
space:
mode:
author Andrew Clemons2019-09-15 07:10:56 +0200
committer Willy Sudiarto Raharjo2019-09-28 12:39:59 +0200
commit89bba633616fe520f6667cdd4af2c70a9e07d64f (patch)
treeb2593193a368fe2f9af6616e5d51f5382accf29a /office
parent862d805fc40baab29c12be550f3ab6a8b62de1ce (diff)
downloadslackbuilds-89bba633616fe520f6667cdd4af2c70a9e07d64f.tar.gz
desktop/zim: Fix DESTDIR handling.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com>
Diffstat (limited to 'office')
-rw-r--r--office/zim/doinst.sh6
-rw-r--r--office/zim/zim.SlackBuild14
2 files changed, 17 insertions, 3 deletions
diff --git a/office/zim/doinst.sh b/office/zim/doinst.sh
index 9a8ded3c60..aea0f894eb 100644
--- a/office/zim/doinst.sh
+++ b/office/zim/doinst.sh
@@ -5,3 +5,9 @@ fi
if [ -x /usr/bin/update-mime-database ]; then
/usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/office/zim/zim.SlackBuild b/office/zim/zim.SlackBuild
index 8437710c83..5c6b19d343 100644
--- a/office/zim/zim.SlackBuild
+++ b/office/zim/zim.SlackBuild
@@ -64,7 +64,7 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$VERSION
chown -R root:root .
@@ -72,12 +72,20 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+./setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-DESTDIR="$PKG" ./setup.py install
+mv $PKG/usr/share/man $PKG/usr/
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/share/icons
+cp -r xdg/hicolor/ $PKG/usr/share/icons/
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION