summaryrefslogtreecommitdiffstats
path: root/office
diff options
context:
space:
mode:
author Dave Woodfall2021-04-22 16:37:48 +0200
committer Dave Woodfall2021-04-22 16:37:48 +0200
commit63d01c6535899696e8ef743c9d831d85dab9fc2e (patch)
tree2edc6c56351f616ef6f5b91779d8075ce7332a3b /office
parent82921597cf4650a5374df29f07c33cfbd3f977cb (diff)
downloadslackbuilds-63d01c6535899696e8ef743c9d831d85dab9fc2e.tar.gz
office/python-gcalcli: Update to 4.3.0. Fix REQUIRES.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org>
Diffstat (limited to 'office')
-rw-r--r--office/python-gcalcli/README33
-rw-r--r--office/python-gcalcli/python-gcalcli.SlackBuild13
-rw-r--r--office/python-gcalcli/python-gcalcli.info8
3 files changed, 21 insertions, 33 deletions
diff --git a/office/python-gcalcli/README b/office/python-gcalcli/README
index 3e86ebdd28..778a6b1c5a 100644
--- a/office/python-gcalcli/README
+++ b/office/python-gcalcli/README
@@ -1,28 +1,13 @@
gcalcli is a Python application that allows you to access your Google
-Calendar from a command line. It's easy to get your agenda, search
-for events, and quickly add new events. Additionally gcalcli can be
-used as a reminder service to execute any application you want.
+Calendar(s) from a command line. It's easy to get your agenda, search
+for events, add new events, delete events, edit events, see recently
+updated events, and even import those annoying ICS/vCal invites from
+Microsoft Exchange and/or other sources. Additionally, gcalcli can be
+used as a reminder service and execute any application you want when an
+event is coming up.
-Features:
+gcalcli uses the Google Calendar API version 3
+(https://developers.google.com/google-apps/calendar/)
-list your calendars
-show an agenda using a specified start/end time and date
-graphical calendar display (my paying homage to the remind application)
-search for past and/or future calendar events
-"quick add" new calendar events to your default calendar
-run as a cron job and execute a command for reminders
-work against specific calendars (by calendar type or calendar name regex)
-config file support for specifying program defaults
-colored output and unicode character support
-easy integration within shell scripts, cron, screen, conky, etc
-
-Not (Yet) Supported:
-
-import meeting.ics Outlook events
-add (non-quick) events with ability to set reminders, repeat, guests, etc
-configurable reminders (i.e. 30 mins before event every 5 mins)
-offline mode working from cached data
-
-The HOWTO here explains options in detail. Taken from:
+The HOWTO here explains options in detail.
http://code.google.com/p/gcalcli/wiki/HowTo
-
diff --git a/office/python-gcalcli/python-gcalcli.SlackBuild b/office/python-gcalcli/python-gcalcli.SlackBuild
index 5cc034cf31..9567670235 100644
--- a/office/python-gcalcli/python-gcalcli.SlackBuild
+++ b/office/python-gcalcli/python-gcalcli.SlackBuild
@@ -22,7 +22,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=python-gcalcli
-VERSION=${VERSION:-git20140429}
+VERSION=${VERSION:-4.3.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -61,7 +61,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.xz
+tar xvf $CWD/$SRCNAM-$VERSION.tar.?z
cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
@@ -70,14 +70,17 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+mv $PKG/usr/share/man $PKG/usr
+gzip -9 $PKG/usr/man/man1/gcalcli.1
+rm -rf $PKG/usr/share
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- ChangeLog README.md docs \
+cp -a ChangeLog LICENSE docs/README.md \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/office/python-gcalcli/python-gcalcli.info b/office/python-gcalcli/python-gcalcli.info
index c2909ce91a..6d2ead6b56 100644
--- a/office/python-gcalcli/python-gcalcli.info
+++ b/office/python-gcalcli/python-gcalcli.info
@@ -1,10 +1,10 @@
PRGNAM="python-gcalcli"
-VERSION="git20140429"
+VERSION="4.3.0"
HOMEPAGE="https://github.com/insanum/gcalcli"
-DOWNLOAD="http://unrealize.co.uk/source/gcalcli-git20140429.tar.xz"
-MD5SUM="c356c275b9e1b69b79a98aabb545d3c5"
+DOWNLOAD="https://github.com/insanum/gcalcli/archive/v4.3.0/gcalcli-4.3.0.tar.gz"
+MD5SUM="9b2a15bd2c52a59627dc70609b0eded0"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="gdata python-dateutil python-elementtree"
+REQUIRES="google-api-python-client python-parsedatetime"
MAINTAINER="David Woodfall"
EMAIL="dave@slackbuilds.org"