summaryrefslogtreecommitdiffstats
path: root/office
diff options
context:
space:
mode:
author Ricardo J. Barberis2019-08-25 03:13:43 +0200
committer Willy Sudiarto Raharjo2019-08-25 03:13:43 +0200
commitd0eaddebf558bab4a61b0f4afb2392a2c29c1f0f (patch)
treec91ed88bc3398bb1ab948edf2d03685b4cbc8336 /office
parentf4b75d1777b8e2adebbdd5385e227237a0c2e367 (diff)
downloadslackbuilds-d0eaddebf558bab4a61b0f4afb2392a2c29c1f0f.tar.gz
office/vmd: Added (Terminal Markdown Viewer).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'office')
-rw-r--r--office/vmd/README10
-rw-r--r--office/vmd/slack-desc19
-rw-r--r--office/vmd/vmd.SlackBuild93
-rw-r--r--office/vmd/vmd.img.patch13
-rw-r--r--office/vmd/vmd.info10
5 files changed, 145 insertions, 0 deletions
diff --git a/office/vmd/README b/office/vmd/README
new file mode 100644
index 0000000000..d3404bf4f5
--- /dev/null
+++ b/office/vmd/README
@@ -0,0 +1,10 @@
+vmd (Terminal Markdown Viewer)
+
+Render markdown in a terminal! Why? Because although Markdown is still
+readable as-is, if you use Markdown a lot, it's nice to have something to
+render it with the proper formatting - with bold text and emphasis, etc.
+
+This package requires Markdown compiled with python3 support
+
+Also, this version is patched to ignore img tags, which make vmd fail
+parsing certain markdown documents.
diff --git a/office/vmd/slack-desc b/office/vmd/slack-desc
new file mode 100644
index 0000000000..72cf8197ee
--- /dev/null
+++ b/office/vmd/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+vmd: vmd (Terminal Markdown Viewer)
+vmd:
+vmd: Render markdown in a terminal! Why? Because although Markdown is
+vmd: still readable as-is, if you use Markdown a lot, it's nice to have
+vmd: something to render it with the proper formatting - with bold text
+vmd: and emphasis, etc.
+vmd:
+vmd: Homegage: https://github.com/cpascoe95/vmd
+vmd:
+vmd:
+vmd:
diff --git a/office/vmd/vmd.SlackBuild b/office/vmd/vmd.SlackBuild
new file mode 100644
index 0000000000..20ad482a58
--- /dev/null
+++ b/office/vmd/vmd.SlackBuild
@@ -0,0 +1,93 @@
+#!/bin/sh
+
+# Slackware build script for vmd
+
+# Copyright 2019 Ricardo J. Barberis <ricardo.barberis@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=vmd
+VERSION=${VERSION:-0.1.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Fix required Markdown version
+sed -i -e 's/Markdown==2.6.8/Markdown>=2.6.8, <3/' requirements.txt setup.py
+
+# Fix, or rather skip, img tags
+patch -p1 < $CWD/vmd.img.patch
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE README.md requirements.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/office/vmd/vmd.img.patch b/office/vmd/vmd.img.patch
new file mode 100644
index 0000000000..3747468550
--- /dev/null
+++ b/office/vmd/vmd.img.patch
@@ -0,0 +1,13 @@
+diff --git a/vmd/parser.py b/vmd/parser.py
+index 2f4f992..df18d07 100644
+--- a/vmd/parser.py
++++ b/vmd/parser.py
+@@ -81,6 +81,8 @@ class TreeBuilder(HTMLParser):
+ self.current_element.add_child(HorizontalRule())
+ elif tag == 'blockquote':
+ self.new_element(tag, Blockquote())
++ elif tag == 'img':
++ pass
+ else:
+ self.logger.warning('Unhandled tag type \'%s\' found in %s', tag, self.current_element.tag_ancestry())
+ self.unknown_tag_stack.append(tag)
diff --git a/office/vmd/vmd.info b/office/vmd/vmd.info
new file mode 100644
index 0000000000..99926d8135
--- /dev/null
+++ b/office/vmd/vmd.info
@@ -0,0 +1,10 @@
+PRGNAM="vmd"
+VERSION="0.1.1"
+HOMEPAGE="https://github.com/cpascoe95/vmd"
+DOWNLOAD="https://github.com/cpascoe95/vmd/archive/v0.1.1/vmd-0.1.1.tar.gz"
+MD5SUM="5dba1bf366780eb2e6bd1ce87e664517"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3 Markdown"
+MAINTAINER="Ricardo J. Barberis"
+EMAIL="ricardo.barberis@gmail.com"