summaryrefslogtreecommitdiffstats
path: root/office
diff options
context:
space:
mode:
author Andrew Payne2019-08-09 18:33:13 +0200
committer Willy Sudiarto Raharjo2019-08-09 18:33:13 +0200
commitaa937480ae19f8b01483b459a211267ea73a0ffc (patch)
tree500a86958b13a20cd84df437aad447189fa60680 /office
parentb44d1d2647d0ff883d7b8484c110fb95c2d1bb62 (diff)
downloadslackbuilds-aa937480ae19f8b01483b459a211267ea73a0ffc.tar.gz
office/zim: Updated for version 0.71.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'office')
-rw-r--r--office/zim/README23
-rw-r--r--office/zim/slack-desc14
-rw-r--r--office/zim/zim.SlackBuild22
-rw-r--r--office/zim/zim.info12
4 files changed, 31 insertions, 40 deletions
diff --git a/office/zim/README b/office/zim/README
index 438f131310..5480b8d446 100644
--- a/office/zim/README
+++ b/office/zim/README
@@ -1,18 +1,15 @@
Zim is a graphical text editor used to maintain a collection of wiki pages.
Each page can contain links to other pages, simple formatting and images.
Pages are stored in a folder structure, like in an outliner, and can have
-attachments. Creating a new page is as easy as linking to a nonexistent page.
-All data is stored in plain text files with wiki formatting. Various plugins
-provide additional functionality, like a task list manager, an equation
-editor, a tray icon, and support for version control.
+attachments. Creating a new page is as easy as linking to a nonexistent
+page. All data is stored in plain text files with wiki formatting. Various
+plugins provide additional functionality, like a task list manager, an
+equation editor, a tray icon, and support for version control.
Zim can be used to:
-* Keep an archive of notes
-* Take notes during meetings or lectures
-* Organize task lists
-* Draft blog entries and emails
-* Do brainstorming
-
-Optional Dependencies:
-* pyxdg - Provides further freedesktop.org standard support
-* See README.Plugins for a list of optional dependencies for plugins
+ * Keep an archive of notes
+ * Keep a daily or weekly journal
+ * Take notes during meetings or lectures
+ * Organize task lists
+ * Draft blog entries and emails
+ * Do brainstorming
diff --git a/office/zim/slack-desc b/office/zim/slack-desc
index f854aa4fb8..f61fe6de72 100644
--- a/office/zim/slack-desc
+++ b/office/zim/slack-desc
@@ -6,14 +6,14 @@
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
-zim: zim (Desktop wiki editor)
+zim: zim (A Desktop Wiki Editor)
zim:
-zim: Zim is a graphical text editor and organizer with wiki-like features
-zim: such as linking to other pages in a notebook. Zim stores data in
-zim: plain text for simplicity and transparency.
-zim:
-zim: Among other uses, zim can be effective for brainstorming,
-zim: note-taking, and making task lists.
+zim: Zim is a graphical text editor used to maintain a collection of wiki
+zim: pages. Each page can contain links to other pages, simple formatting
+zim: and images. Pages are stored in a folder structure, like in an
+zim: outliner, and can have attachments.
zim:
zim: Homepage: http://zim-wiki.org/
zim:
+zim:
+zim:
diff --git a/office/zim/zim.SlackBuild b/office/zim/zim.SlackBuild
index c924515c04..5cd8008e99 100644
--- a/office/zim/zim.SlackBuild
+++ b/office/zim/zim.SlackBuild
@@ -2,8 +2,9 @@
# Slackware build script for zim
-# Copyright 2013 Michael Ren <micron33@gmail.com>
+# Copyright 2019 Andrew Payne <phalange@komputermatrix.com>
# Copyright 2015-2017 Brenton Earl <brent@exitstatusone.com>
+# Copyright 2013 Michael Ren <micron33@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +25,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=zim
-VERSION=${VERSION:-0.68}
+SRCNAM=zim-desktop-wiki
+VERSION=${VERSION:-0.71.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -41,7 +43,7 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-DOCS="CHANGELOG.txt LICENSE.txt PKG-INFO README.txt"
+DOCS="CHANGELOG.md CONTRIBUTING.md LICENSE PLUGIN_WRITING.md README.md"
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
@@ -63,8 +65,8 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -72,21 +74,13 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# zim's setup.py subclasses distutil's install class, adding a flag to disable
-# running update-desktop-database and update-mime-database during the install
-# ("automation"), hence --skip-xdg-cmd
-python setup.py install --root=$PKG --skip-xdg-cmd
-
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-mv $PKG/usr/share/man $PKG/usr
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+DESTDIR="$PKG" ./setup.py install
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/README.Plugins > $PKG/usr/doc/$PRGNAM-$VERSION/README.Plugins
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/office/zim/zim.info b/office/zim/zim.info
index 1b98172ac9..d9b5c95082 100644
--- a/office/zim/zim.info
+++ b/office/zim/zim.info
@@ -1,10 +1,10 @@
PRGNAM="zim"
-VERSION="0.68"
+VERSION="0.71.1"
HOMEPAGE="http://zim-wiki.org/"
-DOWNLOAD="http://zim-wiki.org/downloads/zim-0.68.tar.gz"
-MD5SUM="336041a16687abb66fd9f604b98407e8"
+DOWNLOAD="https://github.com/zim-desktop-wiki/zim-desktop-wiki/archive/0.71.1.tar.gz"
+MD5SUM="8f73ec0046d2c879c8459d3bae5c0b36"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Brenton Earl"
-EMAIL="brent@exitstatusone.com"
+REQUIRES="pygobject3-python3"
+MAINTAINER="Andrew Payne"
+EMAIL="phalange@komputermatrix.com"