summaryrefslogtreecommitdiffstats
path: root/office
diff options
context:
space:
mode:
author Christoph Willing2019-10-01 04:27:28 +0200
committer Willy Sudiarto Raharjo2019-10-05 08:51:59 +0200
commit9f1e850d8145896b5ea4116a909c52786dcf15a9 (patch)
tree2115b013a90480beaab992f93ec7cfd6960b2d4c /office
parent20ad07f88a7f4446b38461c1fa0d8f6bb7bd554f (diff)
downloadslackbuilds-9f1e850d8145896b5ea4116a909c52786dcf15a9.tar.gz
office/LibreOffice: Ensure build finds correct nss/nspr for xmlsec
Signed-off-by: Christoph Willing <chris.willing@linux.com>
Diffstat (limited to 'office')
-rw-r--r--office/LibreOffice/LibreOffice.SlackBuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/office/LibreOffice/LibreOffice.SlackBuild b/office/LibreOffice/LibreOffice.SlackBuild
index f283a7bbf6..000bc0dd38 100644
--- a/office/LibreOffice/LibreOffice.SlackBuild
+++ b/office/LibreOffice/LibreOffice.SlackBuild
@@ -28,7 +28,7 @@ PRGNAM=LibreOffice
SRCNAM=libreoffice
VERSION=${VERSION:-6.2.5.2}
SHORT_VERSION=${VERSION%.*.*}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PACKAGER=${PACKAGER:-"AnonymousCoward"}
@@ -136,7 +136,13 @@ if pkg-config --exists mdds-1.4 ; then mdds="--with-system-mdds" ; else mdds=""
if pkg-config --exists mythes ; then mythes="--with-system-mythes" ; else mythes="" ; fi
if test -x /usr/bin/odbc_config ; then odbc="--with-system-odbc" ; else odbc="" ; fi
#if test -d /usr/lib${LIBDIRSUFFIX}/python3*/site-packages/lxml ; then lxml="--with-system-lxml" ; else lxml="" ; fi
-if pkg-config --exists xmlsec1 ; then xmlsec="--with-system-xmlsec" ; else xmlsec="" ; fi
+if pkg-config --exists xmlsec1 ; then
+ xmlsec="--with-system-xmlsec"
+else
+ xmlsec=""
+ # Also ensure correct nspr implementation is used if building libreoffice supplied xmlsec
+ sed -i -e 's:openssl:openssl --with-mozilla-ver=/usr:' external/xmlsec/ExternalProject_xmlsec.mk
+fi
#if test -e /usr/share/ant/lib/rhino.jar ; then rhino="--with-system-rhino --with-rhino-jar=/usr/share/ant/lib/rhino.jar" ; else rhino="" ; fi
if pkg-config --exists libvlc ; then vlc="--enable-vlc" ; else vlc="" ; fi
# Building with vlc backend is marked as experimental so demand explicit indication via environment variable VLC to do it.