summaryrefslogtreecommitdiffstats
path: root/office
diff options
context:
space:
mode:
author David Woodfall2013-06-04 23:15:41 +0200
committer Robby Workman2013-06-05 10:17:43 +0200
commit0c02fa1068b935b037f196957f13f05bac30e110 (patch)
tree28fcf621b3365ba600c9d223a20a17968e2bcfad /office
parent4db6e48ff8b2c8869da04b711f3275c34215279c (diff)
downloadslackbuilds-0c02fa1068b935b037f196957f13f05bac30e110.tar.gz
office/gcal: Added (Gnu terminal calendar application)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'office')
-rw-r--r--office/gcal/README10
-rw-r--r--office/gcal/gcal.SlackBuild105
-rw-r--r--office/gcal/gcal.info10
-rw-r--r--office/gcal/slack-desc19
4 files changed, 144 insertions, 0 deletions
diff --git a/office/gcal/README b/office/gcal/README
new file mode 100644
index 0000000000..5501b16517
--- /dev/null
+++ b/office/gcal/README
@@ -0,0 +1,10 @@
+Gcal is a program for calculating and printing calendars. Gcal displays
+hybrid and proleptic Julian and Gregorian calendar sheets, respectively
+for one month, three months, or a whole year. It also displays eternal
+holiday lists for many countries around the globe, and features a very
+powerful creation of fixed date liststhat can be used for reminding
+purposes. Gcal can calculate various astronomical data and times of the
+Sun and the Moon for pleasure at any location, precisely enough for most
+civil purposes. Gcal supports some other calendar systems, for example,
+the Chinese and Japanese calendars, the Hebrew calendar, and the civil
+Islamic calendar, too.
diff --git a/office/gcal/gcal.SlackBuild b/office/gcal/gcal.SlackBuild
new file mode 100644
index 0000000000..cf08702e05
--- /dev/null
+++ b/office/gcal/gcal.SlackBuild
@@ -0,0 +1,105 @@
+#!/bin/sh
+
+# Slackware build script for gcal
+# Copyright 2013 Dave Woodfall <dave@dawoodfall.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=gcal
+VERSION=${VERSION:-3.6.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+rm -f $PKG/usr/info/dir
+gzip -9 $PKG/usr/info/*.info*
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS TODO doc/en/examples \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+rm -f $PKG/usr/share/gcal/Makefile.in
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/office/gcal/gcal.info b/office/gcal/gcal.info
new file mode 100644
index 0000000000..8b0a589379
--- /dev/null
+++ b/office/gcal/gcal.info
@@ -0,0 +1,10 @@
+PRGNAM="gcal"
+VERSION="3.6.3"
+HOMEPAGE="http://www.gnu.org/software/gcal/"
+DOWNLOAD="http://ftp.gnu.org/gnu/gcal/gcal-3.6.3.tar.xz"
+MD5SUM="1a195b4673f3330e9031e0f966ac3fea"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="David Woodfall"
+EMAIL="dave@dawoodfall.net"
diff --git a/office/gcal/slack-desc b/office/gcal/slack-desc
new file mode 100644
index 0000000000..47e44ff66e
--- /dev/null
+++ b/office/gcal/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+gcal: gcal ( Gnu terminal calendar application )
+gcal:
+gcal: Gcal is a program for calculating and printing calendars. Gcal
+gcal: displays hybrid and proleptic Julian and Gregorian calendar sheets,
+gcal: respectively for one month, three months, or a whole year. It also
+gcal: displays eternal holiday lists for many countries around the globe,
+gcal: and features a very powerful creation of fixed date lists that can be
+gcal: used for reminding purposes.
+gcal:
+gcal: Homepage: http://www.gnu.org/software/gcal/
+gcal: