summaryrefslogtreecommitdiffstats
path: root/office/org-mode
diff options
context:
space:
mode:
author Robby Workman2020-01-02 23:32:45 +0100
committer Robby Workman2020-01-03 06:33:47 +0100
commit7b7741829053318d4bfb7d37ccc5623c6d3cb372 (patch)
tree38437739329e8c37f6c83dfca0610346b68201c5 /office/org-mode
parent200b1704c1607a6653b3e1ffb7648c323a0a4fb5 (diff)
downloadslackbuilds-7b7741829053318d4bfb7d37ccc5623c6d3cb372.tar.gz
office/org-mode: Removed (org is included in emacs now)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'office/org-mode')
-rw-r--r--office/org-mode/Makefile.patch29
-rw-r--r--office/org-mode/README18
-rw-r--r--office/org-mode/org-mode.SlackBuild65
-rw-r--r--office/org-mode/org-mode.info10
-rw-r--r--office/org-mode/slack-desc19
5 files changed, 0 insertions, 141 deletions
diff --git a/office/org-mode/Makefile.patch b/office/org-mode/Makefile.patch
deleted file mode 100644
index 7daae18e01..0000000000
--- a/office/org-mode/Makefile.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- Makefile.back 2011-10-14 00:08:29.754834385 +0400
-+++ Makefile 2011-10-14 00:47:36.227996214 +0400
-@@ -14,7 +14,7 @@
- EMACS=emacs
-
- # Where local software is found
--prefix=/usr/local
-+prefix=${DESTDIR}
-
- # Where local lisp files go.
- lispdir = $(prefix)/share/emacs/site-lisp
-@@ -246,7 +246,7 @@
-
- doc/org.html: doc/org.texi
- (cd doc && $(TEXI2HTML) --no-split -o org.html org.texi)
-- UTILITIES/manfull.pl doc/org.html
-+# UTILITIES/manfull.pl doc/org.html
-
- doc/orgcard.pdf: doc/orgcard.tex
- (cd doc && pdftex orgcard.tex)
-@@ -277,7 +277,7 @@
- $(TEXI2HTML) -o doc/guide doc/orgguide.texi
- UTILITIES/guidesplit.pl doc/guide/*.html
-
--info: doc/org
-+info: doc/org-7.7
-
- pdf: doc/org.pdf doc/orgguide.pdf
-
diff --git a/office/org-mode/README b/office/org-mode/README
deleted file mode 100644
index ca97958eca..0000000000
--- a/office/org-mode/README
+++ /dev/null
@@ -1,18 +0,0 @@
-Org is an Emacs mode for keeping notes, maintaining TODO lists, and
-doing project planning with a fast and effective plain-text system.
-
-Org keeps simple things simple. When first fired up, it should feel
-like a straightforward, easy to use outliner. Complexity is not
-imposed, but a large amount of functionality is available when you
-need it. Org is a toolbox and can be used in different ways, for
-example as:
-
-- an outline extension with visibility cycling and structure editing
-- an ASCII system and table editor for taking structured notes
-- an ASCII table editor with spreadsheet-like capabilities
-- a TODO list editor
-- a full agenda and planner with deadlines and work scheduling
-- an environment to implement David Allen's GTD system
-- a basic database application
-- a simple hypertext system, with HTML and LaTeX export
-- a publishing tool to create a set of interlinked webpages
diff --git a/office/org-mode/org-mode.SlackBuild b/office/org-mode/org-mode.SlackBuild
deleted file mode 100644
index cabce06e4c..0000000000
--- a/office/org-mode/org-mode.SlackBuild
+++ /dev/null
@@ -1,65 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for Org-mode
-
-# Written by Valeriy Timchenko <ValTimchenko@gmail.com>
-
-PRGNAM=org-mode
-VERSION=${VERSION:-7.7}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-ARCH="noarch"
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf org-$VERSION
-tar xvf $CWD/org-$VERSION.tar.gz
-cd org-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-patch Makefile $CWD/Makefile.patch
-DESTDIR=/usr make all html
-mv doc/{org,org-$pkgver}
-DESTDIR=$PKG/usr make install
-DESTDIR=$PKG/usr make install-info
-#DESTDIR=$PKG/usr PKG=$PKG make install-info
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-rm -f $PKG/usr/share/info/dir
-gzip -9 $PKG/usr/share/info/*
-# Move org.gz to org-$VERSION.gz, so EMACS's org.gz won't be overwritten
-mv $PKG/usr/share/info/{org,org-$VERSION}.gz
-mv $PKG/usr/share/info $PKG/usr/info
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- README request-assign-future.txt doc/*.pdf doc/*.html \
- $PKG/usr/doc/$PRGNAM-$VERSION
-
-# Move contrib/ to /usr/share/org-mode-$VERSION
-mkdir -p $PKG/usr/share/$PRGNAM-$VERSION
-cp -R contrib $PKG/usr/share/$PRGNAM-$VERSION
-
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/office/org-mode/org-mode.info b/office/org-mode/org-mode.info
deleted file mode 100644
index 6cc37ba33c..0000000000
--- a/office/org-mode/org-mode.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="org-mode"
-VERSION="7.7"
-HOMEPAGE="https://orgmode.org"
-DOWNLOAD="https://orgmode.org/org-7.7.tar.gz"
-MD5SUM="236289876d9c33ac47c6383ec738ce6a"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="jdk"
-MAINTAINER="Valeriy Timchenko"
-EMAIL="ValTimchenko@gmail.com"
diff --git a/office/org-mode/slack-desc b/office/org-mode/slack-desc
deleted file mode 100644
index 93d6f3ab85..0000000000
--- a/office/org-mode/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-org-mode: org-mode ("An Emacs mode for Notes, Project Planning, and Authoring")
-org-mode:
-org-mode: Org-mode is for keeping notes, maintaining ToDo lists, doing project
-org-mode: planning, and authoring with a fast and effective plain-text system.
-org-mode:
-org-mode:
-org-mode:
-org-mode:
-org-mode: Org-mode home page is: https://orgmode.org
-org-mode:
-org-mode: