summaryrefslogtreecommitdiffstats
path: root/office/org-mode/org-mode.SlackBuild
diff options
context:
space:
mode:
author Valeriy Timchenko2010-05-13 01:00:34 +0200
committer David Somero2010-05-13 01:00:34 +0200
commit65c913a07947069993ae096a55936915c22d53df (patch)
tree72237748a6b323bdd135527be3f83ed101cacc65 /office/org-mode/org-mode.SlackBuild
parent03e0b9e3adbd2db085fd85f15645fb1a517cba47 (diff)
downloadslackbuilds-65c913a07947069993ae096a55936915c22d53df.tar.gz
office/org-mode: Added to 13.0 repository
Diffstat (limited to 'office/org-mode/org-mode.SlackBuild')
-rw-r--r--office/org-mode/org-mode.SlackBuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/office/org-mode/org-mode.SlackBuild b/office/org-mode/org-mode.SlackBuild
new file mode 100644
index 0000000000..50ed7edc2e
--- /dev/null
+++ b/office/org-mode/org-mode.SlackBuild
@@ -0,0 +1,69 @@
+#!/bin/sh
+
+# Slackware build script for Org-mode
+
+# Written by Valeriy Timchenko <ValTimchenko@gmail.com>
+
+PRGNAM=org-mode
+VERSION=${VERSION:-6.34c}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf org-$VERSION
+tar xvf $CWD/org-$VERSION.tar.gz
+cd org-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+patch Makefile $CWD/Makefile.1.patch
+make
+patch Makefile $CWD/Makefile.2.patch
+PKG=$PKG make install
+PKG=$PKG make install-info
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+)
+
+rm -f $PKG/usr/info/dir
+gzip -9 $PKG/usr/info/*
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a ChangeLog Changes.org README request-assign-future.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}