summaryrefslogtreecommitdiffstats
path: root/office/coolreader
diff options
context:
space:
mode:
author B. Watson2022-02-18 10:01:56 +0100
committer Willy Sudiarto Raharjo2022-02-19 06:09:28 +0100
commit6eca0c94bee2f238dd1333bcc8d837be0eac07fb (patch)
treebd78ba28f526832fea64743dae71bf792436313d /office/coolreader
parent2b1a8cd49c3ada5d7262b7d3ab334719ab551ace (diff)
downloadslackbuilds-6eca0c94bee2f238dd1333bcc8d837be0eac07fb.tar.gz
office/coolreader: Updated for version 3.2.59.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'office/coolreader')
-rw-r--r--office/coolreader/README9
-rw-r--r--office/coolreader/coolreader.SlackBuild50
-rw-r--r--office/coolreader/coolreader.info8
3 files changed, 38 insertions, 29 deletions
diff --git a/office/coolreader/README b/office/coolreader/README
index 098d3573ab..1e618f1f88 100644
--- a/office/coolreader/README
+++ b/office/coolreader/README
@@ -1,16 +1,11 @@
coolreader (e-book reader)
-CoolReader is an e-book reader for various platforms.
+CoolReader is an e-book reader for various platforms, with a Qt5 user
+interface.
Supported file formats include plain text, HTML, RTF, Microsoft Word
(.doc), Palm Pilot (.prc, .pdb, .pml, .mobi), FB2, and EPUB.
-Optional dependencies: The default user interface is Qt5, which
-doesn't require anything extra. If you prefer wxWidgets, install
-wxPython, then run:
-
- GUI=wx ./coolreader.SlackBuild
-
Note: coolreader is "chatty": it logs a lot of meaningless warnings
and errors to stderr. Unless there's an actual problem with the
application, you can ignore this stuff.
diff --git a/office/coolreader/coolreader.SlackBuild b/office/coolreader/coolreader.SlackBuild
index 2d3d9c196d..65b8c97871 100644
--- a/office/coolreader/coolreader.SlackBuild
+++ b/office/coolreader/coolreader.SlackBuild
@@ -23,6 +23,11 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220218 bkw: update for v3.2.59. To get it to build, had to disable
+# unrar support... which didn't exist in v3.2.57, so nobody will miss
+# it, I hope. Also, wxWidgets support fails to build, so that's now
+# disabled (and removed from the README).
+
# 20210930 bkw: update for v3.2.57. This is not the latest release, but
# 3.2.58 fails to build. Will revisit when the next release happens. If
# you can't wait that long, send me a patch (does anyone even use this?)
@@ -58,7 +63,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=coolreader
-VERSION=${VERSION:-3.2.57}
+VERSION=${VERSION:-3.2.59}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -119,26 +124,36 @@ sed -i "s,share/doc/cr3,doc/$PRGNAM-$VERSION," cr3qt/CMakeLists.txt
# into Qt Designer and saving it again. Needed because upstream's
# using a different (older?) version of qt4.
-GUI=${GUI:-QT5}
-GUI="$( echo $GUI | tr a-z A-Z )"
-case "$GUI" in
- # 20210930 bkw: Qt4 disabled for now, unless/until SBo gets a qt4 build.
- #QT) UI=Qt4
- #sed -i '/<property name="currentText"/s,>, stdset="0">,' cr3qt/src/settings.ui
- #;;
- QT5) UI=Qt5 ;;
- WX) # Only 2.8.x works, be specific in the slack-desc.
- UI="wxWidgets 2.8"
- SLKCFLAGS+=" $( wx-config --version=2.8 --cflags )"
- SLKLDFLAGS="$( wx-config --version=2.8 --libs )" ;;
- *) echo "*** Unsupported GUI '$GUI', use one of: QT5 WX"
- exit 1 ;;
-esac
+if true; then
+ # 20220218 bkw: only the qt5 UI works in 3.2.59, sorry.
+ GUI=QT5
+ UI=Qt5
+else
+ # 20220218 bkw: wxWidgets is broken (for either 2.8 or 3.0),
+ # this section of code can't run, it's left for reference.
+ GUI=${GUI:-QT5}
+ GUI="$( echo $GUI | tr a-z A-Z )"
+ case "$GUI" in
+ # 20210930 bkw: Qt4 disabled for now, unless/until SBo gets a qt4 build.
+ #QT) UI=Qt4
+ #sed -i '/<property name="currentText"/s,>, stdset="0">,' cr3qt/src/settings.ui
+ #;;
+ QT5) UI=Qt5 ;;
+ WX) # Only 2.8.x works, be specific in the slack-desc.
+ UI="wxWidgets 2.8"
+ SLKCFLAGS+=" $( wx-config --version=2.8 --cflags )"
+ SLKLDFLAGS="$( wx-config --version=2.8 --libs )" ;;
+ *) echo "*** Unsupported GUI '$GUI', use one of: QT5 WX"
+ exit 1 ;;
+ esac
+fi
# 20201103 bkw: Alt+F for the File menu, Alt+V for View, etc. This
# has been a UI standard since before Windows 1.0 (MS-DOS apps had it),
# and I'm not sure why upstream didn't include it. Only affects the
-# Qt4/5 UIs.
+# Qt4/5 UIs. Incomplete: you can't press Alt+F followed by O for
+# File -> Open... but you can use the arrow keys to navigate the
+# menus once one of them has been opened.
sed -i 's,>\(File\|View\|Navigation\|Help\)<,>\&amp;\1<,' \
cr3qt/src/mainwindow.ui
@@ -166,6 +181,7 @@ cd build
-D MAX_IMAGE_SCALE_MUL=2 \
-D DOC_DATA_COMPRESSION_LEVEL=3 \
-D DOC_BUFFER_SIZE=0x1400000 \
+ -U USE_UNRAR \
-D GUI=$GUI ..
make VERBOSE=1
make install/strip DESTDIR=$PKG
diff --git a/office/coolreader/coolreader.info b/office/coolreader/coolreader.info
index 50da3da8d6..9a1d4cde54 100644
--- a/office/coolreader/coolreader.info
+++ b/office/coolreader/coolreader.info
@@ -1,10 +1,8 @@
PRGNAM="coolreader"
-VERSION="3.2.57"
+VERSION="3.2.59"
HOMEPAGE="https://github.com/buggins/coolreader"
-DOWNLOAD="https://github.com/buggins/coolreader/archive/cr3.2.57/coolreader-cr3.2.57.tar.gz \
- https://github.com/adah1972/libunibreak/releases/download/libunibreak_4_3/libunibreak-4.3.tar.gz"
-MD5SUM="c4bd8c7f9f8de63b9e5bfa1a40287263 \
- f0c4488fad8dc92a11f4523d22c099d3"
+DOWNLOAD="https://github.com/buggins/coolreader/archive/cr3.2.59/coolreader-cr3.2.59.tar.gz"
+MD5SUM="57a8372117209c8a4b5c37e7dee37885"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="libunibreak"