summaryrefslogtreecommitdiffstats
path: root/office/coolreader
diff options
context:
space:
mode:
author B. Watson2021-10-01 07:41:21 +0200
committer Willy Sudiarto Raharjo2021-10-12 19:52:30 +0200
commit28e52a2358debaef9ab4633a5605660e47c1e7e3 (patch)
tree30beb82ec793dfedc23c8cf04c15452b3cb8a6f3 /office/coolreader
parentc9f43e869bb8f7021725c53178bc56fbbc962a13 (diff)
downloadslackbuilds-28e52a2358debaef9ab4633a5605660e47c1e7e3.tar.gz
office/coolreader: Updated for version 3.2.57.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'office/coolreader')
-rw-r--r--office/coolreader/README10
-rw-r--r--office/coolreader/coolreader.SlackBuild55
-rw-r--r--office/coolreader/coolreader.info14
3 files changed, 31 insertions, 48 deletions
diff --git a/office/coolreader/README b/office/coolreader/README
index ca7de57c79..098d3573ab 100644
--- a/office/coolreader/README
+++ b/office/coolreader/README
@@ -5,13 +5,11 @@ CoolReader is an e-book reader for various platforms.
Supported file formats include plain text, HTML, RTF, Microsoft Word
(.doc), Palm Pilot (.prc, .pdb, .pml, .mobi), FB2, and EPUB.
-Optional dependencies: The default user interface is Qt4, which
-doesn't require anything extra. If you prefer Qt5 or wxWidgets:
+Optional dependencies: The default user interface is Qt5, which
+doesn't require anything extra. If you prefer wxWidgets, install
+wxPython, then run:
-qt5 - install qt5, then run: GUI=qt5 ./coolreader.SlackBuild
-
-wx - install wxPython or wxGTK3 (last one installed 'wins'), then run:
- GUI=wx ./coolreader.SlackBuild
+ GUI=wx ./coolreader.SlackBuild
Note: coolreader is "chatty": it logs a lot of meaningless warnings
and errors to stderr. Unless there's an actual problem with the
diff --git a/office/coolreader/coolreader.SlackBuild b/office/coolreader/coolreader.SlackBuild
index 2c79b31423..2d3d9c196d 100644
--- a/office/coolreader/coolreader.SlackBuild
+++ b/office/coolreader/coolreader.SlackBuild
@@ -23,6 +23,15 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20210930 bkw: update for v3.2.57. This is not the latest release, but
+# 3.2.58 fails to build. Will revisit when the next release happens. If
+# you can't wait that long, send me a patch (does anyone even use this?)
+# - remove fribidi from DOWNLOAD, -current's is new enough now.
+# - remove libunibreak from DOWNLOAD, add to REQUIRES (SBo's libunibreak
+# is now new enough to use for coolreader).
+# - drop QT (qt4) GUI option since qt4's not on SBo (yet?).
+# - wxGTK3 build no longer works, for GUI=wx require wxPython 2.8.
+
# 20210222 bkw: update for v3.2.54. Upstream no longer ships libunibreak
# and fribidi source, so add them to DOWNLOAD. Replace qt4_settings_ui.diff
# with a more robust sed command. Add -fpermissive. Sigh.
@@ -49,7 +58,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=coolreader
-VERSION=${VERSION:-3.2.54}
+VERSION=${VERSION:-3.2.57}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -62,9 +71,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -90,32 +96,15 @@ fi
set -e
-FBDVER=${FBDVER:-1.0.10}
-LUBVER=${LUBVER:-4.3}
-
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-cr$VERSION
tar xvf $CWD/$PRGNAM-cr$VERSION.tar.gz
cd $PRGNAM-cr$VERSION
-( cd thirdparty
- tar xvf $CWD/fribidi-$FBDVER.tar.xz
- tar xvf $CWD/libunibreak-$LUBVER.tar.gz )
find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
\! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
-# Apply coolreader-specific patches to thirdparty libs.
-( cd thirdparty/fribidi-$FBDVER
- for i in ../../thirdparty_repo/patches/fribidi/*.patch; do
- patch -p1 < $i
- done )
-
-( cd thirdparty/libunibreak-$LUBVER
- for i in ../../thirdparty_repo/patches/libunibreak/*.patch; do
- patch -p1 < $i
- done )
-
# FFS, it's 2020, we don't need GUI apps hardcoded to start at
# 640x400 window size. Honestly we don't need them hardcoded at
# all, but since that's what coolreader does, pick a size that's
@@ -123,12 +112,6 @@ find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
sed -i 's,\(<height>\)400,\11024,' cr3qt/src/mainwindow.ui
sed -i 's,\(<width>\)600,\11280,' cr3qt/src/mainwindow.ui
-# Use bundled libunibreak, ours is too old (3.0).
-# Use bundled fribidi, Pat's is too old (0.19.7).
-sed -i -e '/find_package(libunibreak)/d' \
- -e '/find_package(FriBidi)/d' \
- CMakeLists.txt
-
# Install the docs in the right place for Slackware.
sed -i "s,share/doc/cr3,doc/$PRGNAM-$VERSION," cr3qt/CMakeLists.txt
@@ -136,16 +119,19 @@ sed -i "s,share/doc/cr3,doc/$PRGNAM-$VERSION," cr3qt/CMakeLists.txt
# into Qt Designer and saving it again. Needed because upstream's
# using a different (older?) version of qt4.
-GUI=${GUI:-QT}
+GUI=${GUI:-QT5}
GUI="$( echo $GUI | tr a-z A-Z )"
case "$GUI" in
- QT) UI=Qt4
- sed -i '/<property name="currentText"/s,>, stdset="0">,' cr3qt/src/settings.ui
- ;;
+ # 20210930 bkw: Qt4 disabled for now, unless/until SBo gets a qt4 build.
+ #QT) UI=Qt4
+ #sed -i '/<property name="currentText"/s,>, stdset="0">,' cr3qt/src/settings.ui
+ #;;
QT5) UI=Qt5 ;;
- WX) # Either 2.8.x or 3.0.x works, be specific in the slack-desc.
- UI="wxWidgets $( wx-config --version | cut -d. -f1,2)" ;;
- *) echo "*** Unsupported GUI '$GUI', use one of: QT QT5 WX"
+ WX) # Only 2.8.x works, be specific in the slack-desc.
+ UI="wxWidgets 2.8"
+ SLKCFLAGS+=" $( wx-config --version=2.8 --cflags )"
+ SLKLDFLAGS="$( wx-config --version=2.8 --libs )" ;;
+ *) echo "*** Unsupported GUI '$GUI', use one of: QT5 WX"
exit 1 ;;
esac
@@ -170,6 +156,7 @@ echo "=== Building $UI GUI"
mkdir -p build
cd build
cmake \
+ -D CMAKE_EXE_LINKER_FLAGS="$SLKLDFLAGS" \
-D USE_UNRAR=1 \
-D CMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-D CMAKE_CXX_FLAGS:STRING="$SLKCFLAGS -fpermissive" \
diff --git a/office/coolreader/coolreader.info b/office/coolreader/coolreader.info
index 975d7c9aee..50da3da8d6 100644
--- a/office/coolreader/coolreader.info
+++ b/office/coolreader/coolreader.info
@@ -1,14 +1,12 @@
PRGNAM="coolreader"
-VERSION="3.2.54"
+VERSION="3.2.57"
HOMEPAGE="https://github.com/buggins/coolreader"
-DOWNLOAD="https://github.com/buggins/coolreader/archive/cr3.2.54/coolreader-cr3.2.54.tar.gz \
- https://github.com/adah1972/libunibreak/releases/download/libunibreak_4_3/libunibreak-4.3.tar.gz \
- https://github.com/fribidi/fribidi/releases/download/v1.0.10/fribidi-1.0.10.tar.xz"
-MD5SUM="b1c15673c84f3171fa9a2c471bb0b54e \
- f0c4488fad8dc92a11f4523d22c099d3 \
- 97c87da9930e8e70fbfc8e2bcd031554"
+DOWNLOAD="https://github.com/buggins/coolreader/archive/cr3.2.57/coolreader-cr3.2.57.tar.gz \
+ https://github.com/adah1972/libunibreak/releases/download/libunibreak_4_3/libunibreak-4.3.tar.gz"
+MD5SUM="c4bd8c7f9f8de63b9e5bfa1a40287263 \
+ f0c4488fad8dc92a11f4523d22c099d3"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="libunibreak"
MAINTAINER="B. Watson"
EMAIL="yalhcru@gmail.com"