summaryrefslogtreecommitdiffstats
path: root/office/calibre/calibre.SlackBuild
diff options
context:
space:
mode:
author Larry Hajali2013-04-08 00:12:53 +0200
committer Robby Workman2013-04-16 00:21:00 +0200
commitf865389b3576be57c0d24f2218c135552abde6b3 (patch)
tree8921797c6f2b0b28f2b0a4fb9c9857700f21c7a5 /office/calibre/calibre.SlackBuild
parentfd8885825ebabe264933a876f95f9d42454c620e (diff)
downloadslackbuilds-f865389b3576be57c0d24f2218c135552abde6b3.tar.gz
office/calibre: Updated for version 0.9.24.
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
Diffstat (limited to 'office/calibre/calibre.SlackBuild')
-rw-r--r--office/calibre/calibre.SlackBuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/office/calibre/calibre.SlackBuild b/office/calibre/calibre.SlackBuild
index 7a34cb9afa..654c308d6d 100644
--- a/office/calibre/calibre.SlackBuild
+++ b/office/calibre/calibre.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=calibre
-VERSION=${VERSION:-0.9.13}
+VERSION=${VERSION:-0.9.24}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -81,6 +81,8 @@ sed -i "/^numeric_version/s|(.*)|(${VERSION//\./, })|" src/calibre/constants.py
# Don't build qt_hack. Calibre dev won't fix. Patch from AlienBob.
# https://bugs.launchpad.net/calibre/+bug/1094719
patch -p1 < $CWD/patches/calibre_noqthack.patch
+# Remove calibre portable scripts.
+rm -f resources/calibre-portable.*
OVERRIDE_CFLAGS="$SLKCFLAGS" \
OVERRIDE_LDFLAGS="-L/usr/lib${LIBDIRSUFFIX}" \
@@ -90,6 +92,9 @@ python setup.py build
# calibre installation while the build process takes place. :/
mkdir -p "$PWD/tmp/config"
+# Hack for installing zsh completion.
+mkdir -p $PKG/usr/share/zsh/site-functions
+
CALIBRE_CONFIG_DIRECTORY="$PWD/tmp/config" \
python setup.py install \
--root=$PKG \
@@ -104,8 +109,9 @@ python setup.py install \
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-# Fix permissions on calibre's bash completion.
-chmod 0755 $PKG/etc/bash_completion.d/$PRGNAM
+# Fix permissions.
+find $PKG/usr/lib${LIBDIRSUFFIX} -iname "*\.py" -exec chmod 0644 '{}' \;
+find $PKG/usr/share/$PRGNAM -type f -exec chmod 0644 '{}' \;
# Install the necessary desktop items.
mkdir -p $PKG/usr/share/{applications,mime/packages}