summaryrefslogtreecommitdiffstats
path: root/office/abiword/abiword.SlackBuild
diff options
context:
space:
mode:
author ponce2012-07-25 12:39:24 +0200
committer Robby Workman2012-08-21 15:55:25 +0200
commit63ea1bca9e4cd63bf79eac0f922eba121a030938 (patch)
tree311d7ae22a5fa0f022d4b79a37d193169c0d3443 /office/abiword/abiword.SlackBuild
parent3db421e8af122d38340edb1a74b90d0089d3ab90 (diff)
downloadslackbuilds-63ea1bca9e4cd63bf79eac0f922eba121a030938.tar.gz
office/abiword: Fixed building with gcc >= 4.6 and glib >= 2.31.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'office/abiword/abiword.SlackBuild')
-rw-r--r--office/abiword/abiword.SlackBuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/office/abiword/abiword.SlackBuild b/office/abiword/abiword.SlackBuild
index 1214057dfd..33f1aef690 100644
--- a/office/abiword/abiword.SlackBuild
+++ b/office/abiword/abiword.SlackBuild
@@ -29,7 +29,7 @@
PRGNAM=abiword
VERSION=2.8.6
DOCSVER=$VERSION # version of abiword-docs
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -82,6 +82,12 @@ patch -p1 < $CWD/patches/boost_asio.patch
# This should make the help stuff work properly
patch -p1 < $CWD/patches/url_show.patch
+# This fixes building with gcc-4.7
+sed -i "s|--no-undefined||" src/Makefile.{am,in}
+
+# This fixes building with glib >= 2.31 (thanks to gentoo)
+patch -p0 < $CWD/patches/abiword-2.8.6-glib-2.31.patch
+
CPPFLAGS="-I$TMP/$PRGNAM-$VERSION" \
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \