summaryrefslogtreecommitdiffstats
path: root/office/Ted
diff options
context:
space:
mode:
author dsomero2010-05-20 02:32:10 +0200
committer David Somero2010-05-21 06:22:24 +0200
commit60e8294a3ec1952e9da64ccb7e40600c95e821e0 (patch)
tree4566c067732372293e9cb5b839b7af42936aab9f /office/Ted
parent1a4daa4e9ab513ea7ea3cc4534ee61d63c29feab (diff)
downloadslackbuilds-60e8294a3ec1952e9da64ccb7e40600c95e821e0.tar.gz
office/Ted: Removed (Won't build due to libpng14)
Diffstat (limited to 'office/Ted')
-rw-r--r--office/Ted/README14
-rw-r--r--office/Ted/Ted.SlackBuild109
-rw-r--r--office/Ted/Ted.info10
-rw-r--r--office/Ted/doinst.sh3
-rw-r--r--office/Ted/slack-desc19
5 files changed, 0 insertions, 155 deletions
diff --git a/office/Ted/README b/office/Ted/README
deleted file mode 100644
index 69dd319685..0000000000
--- a/office/Ted/README
+++ /dev/null
@@ -1,14 +0,0 @@
-Ted is a lightweight Word-processor that uses the RTF-format. It supports
-multiple fonts and can print to PostScript printers. Ted is simple to use,
-is easily compiled.
-
-Additional packages with spellcheckers for different languages exist and
-can be downloaded from the Ted homepage.
-
-Ted can be compiled with different toolkits, which defaults to GTK. To define
-another toolkit (Choices are GTK, MOTIF and QT), you can specify this on the
-commandline:
-
-TOOLKIT=MOTIF ./Ted.SlackBuild
-
-
diff --git a/office/Ted/Ted.SlackBuild b/office/Ted/Ted.SlackBuild
deleted file mode 100644
index 8caf1663f5..0000000000
--- a/office/Ted/Ted.SlackBuild
+++ /dev/null
@@ -1,109 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for Ted
-# and edited by Hannes Worst <hannesworst@gmail.com>.
-# Copyright by Hannes Worst
-#--
-# Last edited: 30-dec-2009
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR `AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# Very heavily edited by the SlackBuilds.org project. --michiel
-
-PRGNAM=Ted
-VERSION=${VERSION:-2.21}
-ARCH=${ARCH:-i686} # Leave this either i686 or x86_64.
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-TOOLKIT=${TOOLKIT:-GTK}
-SRCNAM=$(echo $PRGNAM | tr T t)
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-fi
-
-set -e # Exit on all errors.
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.src.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# Let's edit Ted's Makefile, so this allows us to package Ted quite properly without
-# actually having to need /usr/local/.
-sed -i 's#./configure#./configure --prefix=/usr/share#g' $TMP/$PRGNAM-$VERSION/Makefile
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-make
-make package.shared DESTDIR=$PKG CONFIGURE_OPTIONS="--with-$TOOLKIT \
- --prefix=/usr/share/$PRGNAM --bindir=/usr/bin \
- --build=$ARCH-slackware-linux"
-
-mkdir -p $PKG/usr/share
-tar -xvf $TMP/$PRGNAM-$VERSION/${SRCNAM}Package/$SRCNAM-$VERSION-linux-$ARCH.tar.gz -C $PKG/usr/share/
-mv $PKG/usr/share/bin $PKG/usr/
-
-mkdir -p $PKG/usr/man/man1
-mv $PKG/usr/share/$PRGNAM/{rtf2pdf,rtf2ps,$PRGNAM}.1 $PKG/usr/man/man1
-mv $PKG/usr/share/$PRGNAM/{rtf2pdf,rtf2ps}.sh $PKG/usr/bin/
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cat $PKG/usr/share/$PRGNAM/$PRGNAM.ad.sample > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.ad.sample
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/usr/share/applications
-mv $PKG/usr/share/$PRGNAM/varia/$PRGNAM.desktop $PKG/usr/share/applications/$PRGNAM.desktop
-sed -i 's#/local/#/share/#' $PKG/usr/share/applications/$PRGNAM.desktop
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
-
diff --git a/office/Ted/Ted.info b/office/Ted/Ted.info
deleted file mode 100644
index 84a9bd53c5..0000000000
--- a/office/Ted/Ted.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="Ted"
-VERSION="2.21"
-HOMEPAGE="http://www.nllgg.nl/Ted/"
-DOWNLOAD="ftp://ftp.nluug.nl/pub/editors/ted/ted-2.21.src.tar.gz"
-MD5SUM="34ae855938a3b364eb587cca504ba356"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="Hannes Worst"
-EMAIL="hannesworst@gmail.com"
-APPROVED="BP{k}"
diff --git a/office/Ted/doinst.sh b/office/Ted/doinst.sh
deleted file mode 100644
index 5fb28930db..0000000000
--- a/office/Ted/doinst.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
diff --git a/office/Ted/slack-desc b/office/Ted/slack-desc
deleted file mode 100644
index c794884dd2..0000000000
--- a/office/Ted/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-Ted: Ted (a lightweight WYSIWYG wordprocessor)
-Ted:
-Ted: Ted is a lightweight wordprocessor that emphasizes simplicity,
-Ted: but with many features.
-Ted: There are additional packages for different languages
-Ted: to be found on the hompage. Ted is simple to use and easily compiled.
-Ted: It starts up quickly.
-Ted:
-Ted: Homepage: http:///www.nllgg.nl/Ted/
-Ted:
-Ted: