summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Pablo Santamaria2014-02-09 02:57:31 +0100
committer Erik Hanson2014-02-11 19:15:06 +0100
commit1be35e49fd8adc9585df13d5e4fa69eda6d17c68 (patch)
treea2efa74505510bad0013d49db2710dda4a0c1422 /network
parent68feb96a400a0fd5bbf05f6e41713822694bb2af (diff)
downloadslackbuilds-1be35e49fd8adc9585df13d5e4fa69eda6d17c68.tar.gz
network/gmapcatcher: Updated for version 0.8.0.4.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/gmapcatcher/gmapcatcher.SlackBuild23
-rw-r--r--network/gmapcatcher/gmapcatcher.info6
-rw-r--r--network/gmapcatcher/patch-setup.diff12
3 files changed, 9 insertions, 32 deletions
diff --git a/network/gmapcatcher/gmapcatcher.SlackBuild b/network/gmapcatcher/gmapcatcher.SlackBuild
index 3f440c13d5..6f2c36ac36 100644
--- a/network/gmapcatcher/gmapcatcher.SlackBuild
+++ b/network/gmapcatcher/gmapcatcher.SlackBuild
@@ -5,8 +5,8 @@
# Written by Pablo Santamaria (pablosantamaria)
PRGNAM=gmapcatcher
-VERSION=${VERSION:-0.7.7.2}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-0.8.0.4}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -41,9 +41,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf GMapCatcher-$VERSION
-tar xvf $CWD/GMapCatcher-$VERSION.tar.gz
-cd GMapCatcher-$VERSION
+rm -rf mapcatcher-$VERSION
+tar xvf $CWD/mapcatcher_${VERSION}.tar.gz
+cd mapcatcher-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -51,19 +51,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Patch setup.py for include tilesRepo
-patch -p1 < $CWD/patch-setup.diff
-
-# Prepare files for install
-rm -rf WindowsMobile
-mv maps.py mapcatcher
-mv download.py mapdownloader
-gzip -9 man/mapcatcher.1
-gzip -9 man/mapdownloader.1
-cp images/map.png images/mapcatcher.png
-chmod a-x gmapcatcher.desktop
-
python setup.py install --root=$PKG
+chmod 644 $PKG/usr/share/applications/gmapcatcher.desktop
( cd $PKG/usr/bin ; ln -s mapcatcher gmapcatcher )
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/network/gmapcatcher/gmapcatcher.info b/network/gmapcatcher/gmapcatcher.info
index 49854684ad..0b0410ae8b 100644
--- a/network/gmapcatcher/gmapcatcher.info
+++ b/network/gmapcatcher/gmapcatcher.info
@@ -1,8 +1,8 @@
PRGNAM="gmapcatcher"
-VERSION="0.7.7.2"
+VERSION="0.8.0.4"
HOMEPAGE="http://code.google.com/p/gmapcatcher/"
-DOWNLOAD="http://gmapcatcher.googlecode.com/files/GMapCatcher-0.7.7.2.tar.gz"
-MD5SUM="02c243c8e5b0ea36f8389bedc5c3ffef"
+DOWNLOAD="http://gmapcatcher.googlecode.com/files/mapcatcher_0.8.0.4.tar.gz"
+MD5SUM="2485bac859e6d7f0135b47329117d301"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/network/gmapcatcher/patch-setup.diff b/network/gmapcatcher/patch-setup.diff
deleted file mode 100644
index 7dc3e22a18..0000000000
--- a/network/gmapcatcher/patch-setup.diff
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ru GMapCatcher-0.7.7.2/setup.py GMapCatcher-0.7.7.2.new/setup.py
---- GMapCatcher-0.7.7.2/setup.py 2012-04-28 10:35:10.000000000 -0300
-+++ GMapCatcher-0.7.7.2.new/setup.py 2012-07-09 11:06:37.054422933 -0300
-@@ -24,7 +24,7 @@
- scripts = ['mapcatcher', 'mapdownloader'],
- packages = ['gmapcatcher', 'gmapcatcher.mapServers',
- 'gmapcatcher.pyGPSD', 'gmapcatcher.pyGPSD.nmea',
-- 'gmapcatcher.pyGPSD.nmea.serial']
-+ 'gmapcatcher.pyGPSD.nmea.serial', 'gmapcatcher.tilesRepo']
- )
- else:
- import py2exe